roko
  •  roko
  • 53% (Neutral)
  • YAF Forumling Topic Starter
2010-11-29T19:51:53Z
Hi,
I am trying install forum with YAF-v1.9.5-FINAL-BIN file.
When I compile codes in VS2010 this error occures
"Unknown server tag 'YAF:TopicLine'. File: Forum\pages\moderate.ascx, Line:76"
what can i do for solving this problem.
another question, how can i attach db file to MSSQL Server2008?
Sponsor
Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer
2010-12-01T07:10:39Z
Add this at the top of the \pages\moderate.ascx file:

<%@ Register TagPrefix="YAF" TagName="TopicLine" Src="../controls/TopicLine.ascx" %>

roko
  •  roko
  • 53% (Neutral)
  • YAF Forumling Topic Starter
2010-12-01T10:49:57Z
Originally Posted by: Jaben 

Add this at the top of the \pages\moderate.ascx file:

<%@ Register TagPrefix="YAF" TagName="TopicLine" Src="../controls/TopicLine.ascx" %>



Thanks for answer but it is not enough to compiling. There is another 3 problems after applying new line.

"Type 'ASP.forum_controls_topicline_ascx' does not have a public property named 'td'." File:\pages\moderate.ascx Line:78
"Type 'ASP.forum_controls_topicline_ascx' does not have a public property named 'ThemeButton'." File:\pages\moderate.ascx Line:79
"Content ('</td>') does not match any properties within a 'ASP.forum_controls_topicline_ascx', make sure it is well-formed." File:\pages\moderate.ascx Line: 82

I am not good about programming but i think this problems relating with inline method. because every pages first line like that "...Codebehind="moderate.ascx.cs" ". There isn't .cs file so it seems a problem.
Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer
2010-12-01T16:36:50Z
Anyway, it's fixed in the latest code. I'll be releasing v1.9.5.1 here in a day or two to fix these issues.
bertb
  •  bertb
  • 64.4% (Friendly)
  • YAF Camper
2010-12-01T16:46:17Z
For a quick workaround you could try:

	<asp:Repeater ID="topiclist" runat="server">
		<ItemTemplate>
			<tr>
				<td class="postheader" align="center" colspan="6">
					<YAF:ThemeButton ID="DeleteTopic" runat="server" CssClass="yafcssbigbutton rightItem" TextLocalizedTag="BUTTON_DELETETOPIC"
						TitleLocalizedTag="BUTTON_DELETETOPIC_TT" OnLoad="Delete_Load" CommandArgument='<%# Eval( "TopicID") %>'
						CommandName='delete' />
				</td>
			</tr>
			<YAF:TopicLine runat="server" DataRow="<%# Container.DataItem %>" />
		</ItemTemplate>
	</asp:Repeater>

Never say "OOPS!" always say "Ah, Interesting!"
roko
  •  roko
  • 53% (Neutral)
  • YAF Forumling Topic Starter
2010-12-01T22:46:08Z
Originally Posted by: bertb 

For a quick workaround you could try:

	<asp:Repeater ID="topiclist" runat="server">
		<ItemTemplate>
			<tr>
				<td class="postheader" align="center" colspan="6">
					<YAF:ThemeButton ID="DeleteTopic" runat="server" CssClass="yafcssbigbutton rightItem" TextLocalizedTag="BUTTON_DELETETOPIC"
						TitleLocalizedTag="BUTTON_DELETETOPIC_TT" OnLoad="Delete_Load" CommandArgument='<%# Eval( "TopicID") %>'
						CommandName='delete' />
				</td>
			</tr>
			<YAF:TopicLine runat="server" DataRow="<%# Container.DataItem %>" />
		</ItemTemplate>
	</asp:Repeater>




After applying this block following error occures:
"The file '/Forum/themes/Yafmobile/controls/TopicLine.ascx.cs' does not exist. File:\Forum\themes\Yafmobile\MobilePages\TopicLine.ascx Line:1"
bertb
  •  bertb
  • 64.4% (Friendly)
  • YAF Camper
2010-12-02T21:18:19Z
That's a different error. Check here 
Never say "OOPS!" always say "Ah, Interesting!"
roko
  •  roko
  • 53% (Neutral)
  • YAF Forumling Topic Starter
2010-12-03T22:20:28Z
milko
  •  milko
  • 54.8% (Neutral)
  • YAF Forumling
2010-12-16T05:07:40Z
fyi

I just downloaded the final 1.9.5 and this error was still happening, I fixed it following these
SilhouetteBS
2010-12-21T21:02:58Z
Originally Posted by: Jaben 

Anyway, it's fixed in the latest code. I'll be releasing v1.9.5.1 here in a day or two to fix these issues.


Any idea when 1.9.5.1 will be available?
Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer
2010-12-22T01:04:53Z
Originally Posted by: SilhouetteBS 

Originally Posted by: Jaben 

Anyway, it's fixed in the latest code. I'll be releasing v1.9.5.1 here in a day or two to fix these issues.


Any idea when 1.9.5.1 will be available?


Unfortunately v1.9.5.1 went way out of scope. Now it's a completely different beast... needs tons more testing.

Not sure when I'll have time for that.
cagliostro
2010-12-22T10:19:37Z
Originally Posted by: Jaben 


Unfortunately v1.9.5.1 went way out of scope. Now it's a completely different beast... needs tons more testing.

Not sure when I'll have time for that.




Sorry to hear that since some of us are stuck in 1.9.5 rtm and that email notification bug.


squirrel
2010-12-22T11:35:44Z
Originally Posted by: cagliostro 

Originally Posted by: Jaben 


Unfortunately v1.9.5.1 went way out of scope. Now it's a completely different beast... needs tons more testing.

Not sure when I'll have time for that.




Sorry to hear that since some of us are stuck in 1.9.5 rtm and that email notification bug.



There were more issues than just the notification bug that came out in 1.9.5 - the developers are working night and day to resolve issues throughout the code. I have been keeping them busy with issues in the bug tracker and they are fixing things every day. You can't expect miracles overnight especially when it comes to free software driven by a community of developers rather than a multi-million dollar corporation. We run a forum with several thousand members and we are all working through the bugs as they are fixed --

Patience, young jedi...

It could be much worse... You could have to run a php based software on your .NET server if YAF didn't even exist.
If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
cagliostro
2010-12-22T13:21:57Z
Originally Posted by: squirrel 



There were more issues than just the notification bug that came out in 1.9.5 - the developers are working night and day to resolve issues throughout the code. I have been keeping them busy with issues in the bug tracker and they are fixing things every day. You can't expect miracles overnight especially when it comes to free software driven by a community of developers rather than a multi-million dollar corporation. We run a forum with several thousand members and we are all working through the bugs as they are fixed --

Patience, young jedi...

It could be much worse... You could have to run a php based software on your .NET server if YAF didn't even exist.



Yes, thanks, but i don't need a lecture about all that, since i didn't complain.

The email notice is the only thing that bugs me right now, and i find it crusial.


About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved