retrofive
2013-12-31T19:13:42Z
So I downloaded 2.1 from gitbub. Followed the readme on upgrading and get the below when trying to run the install:

UserPostedImage

I am very new to this, so sorry if it is obvious.

Currently running 2.0 on Windows Server 2008, MS SQL 2008, "standalone"

Sponsor
Zero2Cool
2013-12-31T19:31:50Z
I can't pinpoint the problem for you, however, I would suggest repackaging the upgrade and trying to do the upgrade again. The repackaging is only applicable if you are downloading the latest version.
retrofive
2013-12-31T19:35:56Z
Originally Posted by: Zero2Cool 

I can't pinpoint the problem for you, however, I would suggest repackaging the upgrade and trying to do the upgrade again. The repackaging is only applicable if you are downloading the latest version.



By re-packaging you mean re-run the build.bat and buildpackages.bat?

I have tried that. Maybe Im doing it wrong. Downloaded the latest this morning, ran the .bat's, copied the folder structure to the live iis folder.
retrofive
2014-01-03T18:33:10Z
Finally was able to build it in VS2012. Says it's it debug mode however and need to re-compile in relase-mode. I'll search around for how.

We still have several issues.

First Unread still doesn't function. (looks like it has been brought back up recently)
Images under the 800 max width are enlarged to 800 making them look funky.
Gofer01
2014-02-04T17:43:19Z
Originally Posted by: retrofive 

Finally was able to build it in VS2012. Says it's it debug mode however and need to re-compile in relase-mode. I'll search around for how.

We still have several issues.

First Unread still doesn't function. (looks like it has been brought back up recently)
Images under the 800 max width are enlarged to 800 making them look funky.



I had the same problem like 3 hours ago on a board that been running 3 months. I change the Inherits="_YAf.***" to the name of my page _Default

Once I did that I finally got the site.Master and the code-be-hind page of site.master and Default.aspx to work.


<%@ Page Title="" Language="C#" MasterPageFile="~/site.master" AutoEventWireup="true" CodeFile="Default.aspx.cs" Inherits="_Default" %>


ZeroToCool was a big help 3 months ago
Michael
My Website 
Zero2Cool
2014-02-04T17:47:40Z
If you're doing a build on the latest commit from github,

Open the solution. Navigate to the file LatestInformationService.cs

Exclude the /YetAnotherForum.NET/Classes/LatestInformationService.cs file, then include it, do a solution rebuild and then run the .bat file. This will produce the ZIP files for an upgrade.

Then to get the release DLL's, just change the build to RELEASE, do a build and copy the DLL's from the /bin to your /bin directory.

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved