Mnauman
  •  Mnauman
  • 61.4% (Friendly)
  • YAF Camper Topic Starter
2020-02-26T10:39:22Z
i am using yaf forum 2.24.18 and when my registered user click on "my albums" to store his images he gets an error message access denied. I gave access to my user to create album from Host settings and also from Roles. you can check attached images.

YAF ISSUES.JPG

YAF ISSUE2.JPG

Access Message is as follow.

YAf issue 3.JPG

URL when user click on "my Albums" is http://forums.punchsoftware.com/info?i=4 

Kindly help me how to give access to user to upload his/her images.
Thanks.
Sponsor
tha_watcha
2020-02-26T12:59:28Z
It would only throw a access denied. if the user id is not provided via the url u=xxx. or the user doesn't exist or is not approved.
UserPostedImage
Mnauman
  •  Mnauman
  • 61.4% (Friendly)
  • YAF Camper Topic Starter
2020-02-26T13:32:43Z
the issue is not with just one user but with every Registered User. For moderators, it works fine, but not for Registered Users.
User is approved and can post in my forum.
tha_watcha
2020-02-26T16:27:26Z
As i wrote before does the links contains the user id parameter(u=xxx)?
UserPostedImage
Mnauman
  •  Mnauman
  • 61.4% (Friendly)
  • YAF Camper Topic Starter
2020-03-04T08:12:36Z
Originally Posted by: tha_watcha 

As i wrote before does the links contains the user id parameter(u=xxx)?


No, it does not contains the user id parameter(u=xxx). the link generated when i click is as follow

http://forums.punchsoftware.com/info?i=4 

tha_watcha
2020-03-04T10:30:59Z
When you are logged in with a registered user and you hover over the my topics link and you right click and then copy link address you would see the actual url

PS. You should upgrade to the lasted version!
UserPostedImage
Mnauman
  •  Mnauman
  • 61.4% (Friendly)
  • YAF Camper Topic Starter
2020-03-04T14:08:55Z
the link is as follow. i got same error message of Access Denied.

http://forums.punchsoftware.com/albums?u=89528 

Thanks
Mnauman
  •  Mnauman
  • 61.4% (Friendly)
  • YAF Camper Topic Starter
2020-03-10T05:46:06Z
Kindly guide me how i can fix this issue. i am waiting for your replay @tha_watcha
tha_watcha
2020-03-10T07:26:03Z
I still can not reproduce the issue with the latest version. Does the error occur with the current version 2.31.02?
UserPostedImage

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved