wiwatdarakai
2008-11-16T17:43:56Z
Befor -I use yaf 1.9.1.8 Final
-I use other user (I have main project,It have forum)
-I use yafUserClass.cs
-I config yetnet
<CustomUserAssembly>TinyGecko.YAFIntegration.dll</CustomUserAssembly>
<CustomUserClass>TinyGecko.YAFIntegration.yafUserClass</CustomUserClass>
But now
-I use yaf 1.9.3
-I have problem other user.
-I have use other user same in v 1.9.1.8
-I hame error

Object reference not set to an instance of an object

in web config

<roleManager enabled="true" defaultProvider="YafRoleProvider">
<providers>
<clear/>
<add connectionStringName="HSROConnectionString" applicationName="YetAnotherForum" name="YafRoleProvider" type="YAF.Providers.Roles.YafRoleProvider"/>
</providers>
</roleManager>
<membership defaultProvider="AspNetSqlMembershipProvider">
<providers>
<clear/>
<add name="AspNetSqlMembershipProvider" connectionStringName="HSROConnectionString" applicationName="/" minRequiredPasswordLength="1" minRequiredNonalphanumericCharacters="0" requiresQuestionAndAnswer="false" requiresUniqueEmail="false" type="System.Web.Security.SqlMembershipProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
</providers>
</membership>

<anonymousIdentification enabled="true" cookieName=".ASPXANONYMOUS" cookieTimeout="43200" cookiePath="/" cookieRequireSSL="false" cookieSlidingExpiration="true" cookieProtection="All" cookieless="UseCookies"/>
<profile defaultProvider="mySqlProfileProvider" automaticSaveEnabled="true" enabled="true" inherits="YAF.Classes.Utils.YafUserProfile">
<providers>
<clear/>
<add name="mySqlProfileProvider" type="System.Web.Profile.SqlProfileProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" connectionStringName="yafnet" applicationName="mynet"/>
</providers>
<properties>
<add name="HasMigrated" type="System.Boolean" defaultValue="false"/>
<add name="Culture" type="System.String" allowAnonymous="true" defaultValue="en-US"/>
<add name="Theme" type="System.String" defaultValue="" readOnly="false"/>
</group>
</properties>
</profile>
Sponsor
Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer
2008-11-19T02:17:30Z
Which admin page? Can you explain where you got this error and provide the full Exception information?

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved