rabiz
  •  rabiz
  • 55.4% (Neutral)
  • YAF Forumling Topic Starter
2009-05-15T02:12:44Z
Hello I had a web with Ajax integration and I integrated a YAF forum on it. My problem is that the DLL version of my ajaxtoolkit (3.0.30512.17815) is different from the one YAF uses (3.0.20229.22157), so it gives that error:

Could not load File or Assembly 'AjaxControlToolkit, Version=3.0.20229.22157, Culture=neutral, PublicKeyToken=28f01b0e84b6d53e' ni una de sus dependencias. La definición del manifiesto del ensamblado no coincide con la referencia al ensamblado. (Excepción de HRESULT: 0x80131040) C:\Documents and Settings\jgaliano\Mis documentos\Visual Studio 2008\WebSites\IntercambiosyVentas\pages\search.ascx

I found a possible solution on this forum that said to add this to web.config :

<runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
<assemblyIdentity name="AjaxControlToolkit" PublicKeyToken="28f01b0e84b6d53e"/>
<bindingRedirect oldVersion="3.0.20229.22157" newVersion="3.0.30512.17815"/>
</dependentAssembly>
</assemblyBinding>
</runtime>

But keeps giving same error, anyone have a clue about how to fix this?

Thanks in advance

Sponsor
logan
  •  logan
  • 100% (Exalted)
  • YAF Leader
2009-05-15T02:42:31Z


net 2.0 ajax control toolkit should be version 1.0.20229

 <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
            <dependentAssembly>
                <assemblyIdentity name="System.Web.Extensions" publicKeyToken="31bf3856ad364e35"/>
                <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/>
            </dependentAssembly>
            <dependentAssembly>
                <assemblyIdentity name="System.Web.Extensions.Design" publicKeyToken="31bf3856ad364e35"/>
                <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/>
            </dependentAssembly>
        </assemblyBinding>
    </runtime>
</configuration>

test
rabiz
  •  rabiz
  • 55.4% (Neutral)
  • YAF Forumling Topic Starter
2009-05-17T22:52:26Z
That is the problem, I wanted to use a newer version of the Control Toolkit 3.0.30512, it has some updates that I need for my Application
rmcbride@rama.com
2009-05-18T09:49:41Z
Hi all

I am having the same problem. So far the only thing I have arrived at is that you CANNOT use the newer version unless you recompile YAF against the newer version of the toolkit.

The version that YAF compiled in .NET 3.5 uses is the 3.0.20229 version. The newest release is the 3.0.30512.17815 and its manifest will obviously not equal the manifest for the older version.

Now since I know absolutely nothing about compiling, this could become quite problematic. I wonder if there is any way to "loosen" the version dependence in a compiled version of YAF.

By the way, this is a problem in many other applications besides YAF.

Thanks

Richard

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved