amirag
  •  amirag
  • 55.4% (Neutral)
  • YAF Forumling Topic Starter
2009-06-10T23:21:52Z
Greetings every one,

when I install yaf , I got this database error(User does not have permission to perform this action.) which refer to fulltext.sql
I'm running YAF on goddady.

after finishing the installation, I find that so many features don't created such as
- can't create new users
- there's no administration panel...etc
here's my forum http://psbwa.org/forum/ 

So, what is this error mean ? what can I do ?

Thanks in advance
Sponsor
amirag
  •  amirag
  • 55.4% (Neutral)
  • YAF Forumling Topic Starter
2009-06-11T00:07:31Z
Here's the full error msg

FILE:
fulltext.sql

ERROR:
User does not have permission to perform this action.

Full-Text catalog 'YafSearch' does not exist in database 'psdbwa' or user does not have permission to perform this action.

STATEMENT:
if (select DATABASEPROPERTY(DB_NAME(), N'IsFullTextEnabled')) = 1

BEGIN

	if not exists (select * from dbo.sysfulltextcatalogs where name = N'YafSearch')

	BEGIN

		EXEC sp_fulltext_catalog N'YafSearch', N'create'

		EXEC sp_fulltext_table N'[dbo].[yaf_Message]', N'create', N'YafSearch', N'PK_yaf_Message'	

		EXEC sp_fulltext_column N'[dbo].[yaf_Message]', N'Message', N'add'

		EXEC sp_fulltext_table N'[dbo].[yaf_Message]', N'activate' 

		EXEC sp_fulltext_table N'[dbo].[yaf_Message]', N'Start_change_tracking'

		EXEC sp_fulltext_table N'[dbo].[yaf_Message]', N'Start_background_updateindex'





		EXEC sp_fulltext_table N'[dbo].[yaf_Topic]', N'create', N'YafSearch', N'PK_yaf_Topic'

		EXEC sp_fulltext_column N'[dbo].[yaf_Topic]', N'Topic', N'add'

		EXEC sp_fulltext_table N'[dbo].[yaf_Topic]', N'activate' 

		EXEC sp_fulltext_table N'[dbo].[yaf_Topic]', N'Start_change_tracking'

		EXEC sp_fulltext_table N'[dbo].[yaf_Topic]', N'Start_background_updateindex'

		

		-- enable in yaf_Registry as a default

		IF EXISTS ( SELECT 1 FROM yaf_Registry where [Name] = N'usefulltextsearch' )

			UPDATE yaf_Registry SET [Value] = '1' WHERE [Name] = N'usefulltextsearch'

		ELSE

			INSERT INTO yaf_Registry ([Name],[Value],[BoardID]) VALUES (N'usefulltextsearch','1',NULL);

	END

END

Mek
  •  Mek
  • 100% (Exalted)
  • YAF Developer
2009-06-11T05:11:12Z
You have installed with Full Text Search, and not got that enabled on your sql. Reinstall without ticking that option.

UserPostedImage 

"It's a case of RTFM.. the only problem being we don't have a manual!"

When I post FP:Mek in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting. (Yes I stole this off Ederon 🙂 )
amirag
  •  amirag
  • 55.4% (Neutral)
  • YAF Forumling Topic Starter
2009-06-13T00:08:24Z
Mek wrote:

Reinstall without ticking that option.


where's that option "Full Text Search" in YAF v 1.9.1.8, I didn't c it through installation steps
I'll upgrade to v1.9.3
amirag
  •  amirag
  • 55.4% (Neutral)
  • YAF Forumling Topic Starter
2009-06-13T09:20:43Z
I installed YAF v1.9.3 (new installation), and I got this exception
 Login failed for user 'PHX3\Iusr_4481723'.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Data.SqlClient.SqlException: Login failed for user 'PHX3\Iusr_4481723'.

Source Error:

Line 545:		private void FixAccess( bool bGrant )
Line 546:		{
Line 547:            DB.system_initialize_fixaccess(bGrant);		
Line 548:		}
Line 549:		#endregion


is "PHX3\Iusr_4481723" should be one of the aspnet_Users table contents ??

Thank You
mddubs
2009-06-13T11:03:41Z
Login failed for user 'PHX3\Iusr_4481723'

That means that user doesn't have access to one of your databases.
UserPostedImage 
www.bunkerhollow.com  | www.careercomputing.com 
When I post fp:mddubs in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting. (Yes I stole this off Mek 🙂, who stole this off Ederon 🙂 )
amirag
  •  amirag
  • 55.4% (Neutral)
  • YAF Forumling Topic Starter
2009-06-13T11:31:40Z
ya, and don't know why!

I changed db.config to be like this


<connectionStrings>
	<add name="yafnet" connectionString="data source=secureserver;initial catalog=mydatabaseName;user id=userId;pwd=mypwd/>
</connectionStrings>


and removed integrated security=SSPI

It works perfectly now :)

http://www.psbwa.org/for...yaf/default.aspx?g=forum 
mddubs
2009-06-13T11:52:35Z
Nice, glad it works. If you want to use Integrated Security, try giving the "NT AUTHORITY/NETWORK SERVICE" login dbo permission to your database.
UserPostedImage 
www.bunkerhollow.com  | www.careercomputing.com 
When I post fp:mddubs in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting. (Yes I stole this off Mek 🙂, who stole this off Ederon 🙂 )
amirag
  •  amirag
  • 55.4% (Neutral)
  • YAF Forumling Topic Starter
2009-06-13T12:14:27Z
I'll try it

Thank you :)

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved