Welcome Guest! To enable all features please Login or Register.
Options
View
Go to last post Go to first unread
Offline Ant82  
#1 Posted : Friday, September 15, 2017 7:07:55 PM(UTC)
Ant82


Rank: YAF Forumling

Reputation:

Joined: 9/15/2017(UTC)
Posts: 4

Hi, Please excuse me as I am new to the forums and YAF. I have used the https://webgallery.micro.../apps/YetAnotherForumNET link to install a completely brand new installation on a Windows 2008 server. The YAF version is 2.2.4.2 . The installation went smoothly and without incident. Everything is working great except for this one bug.

I posted to the new forum the forum rules. At the time, the formatting looked correct, preview looked fine, and I posted. The post was formatted correctly. The next day I came back to the post and all the formatting was gone. The paragraph breaks were removed and it looked terrible. I clicked the edit button and the post shows the correct formatting in the edit box, but now the preview does not and if I hit post the formatting is ignored. Changing the editors has no effect. Any ideas?

Untitled-2.png
Untitled-1.png
Sponsor
Offline tha_watcha  
#2 Posted : Sunday, September 17, 2017 11:05:11 AM(UTC)
tha_watcha


Rank: YAF.NET Project Lead

Reputation:

Medals: Medal of Honor: Portal Puzzle Master: Portal Puzzle Master for DNNMedal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.DNN Master: DNN Module ManBug Killer Medal of Honor: Medal for being a kick-ass bug killer!Medal of Honor for the Support King: Support King! Amazing asset to the YAF.NET Community.

Joined: 3/6/2010(UTC)
Posts: 3,743
Germany

Thanks: 70 times
Was thanked: 1149 time(s) in 979 post(s)
And the post was not edited after you created it? that would be the first explanation.

Also are all html tags inside the post are allowed via the host settings?

Is the forum public so i can take a look?
Offline Ant82  
#3 Posted : Monday, September 18, 2017 12:59:29 AM(UTC)
Ant82


Rank: YAF Forumling

Reputation:

Joined: 9/15/2017(UTC)
Posts: 4

I thanks for the reply. I checked and I suspect I found where and why it was happening. At work, the post and editor is being handled by the ckeditor in Firefox on a desktop. When away or when connecting through a mobile firefox the default editor switches to the standard BB editor. I looked through the Host-> Editor settings and could not find a place to set the mobile theme editor to ckeditor. I assumed once the global editor was set and the option to let users pick an editor was unchecked even the mobile themes would use the global editor, but this does not seem to be the case.

All html tags seems to be in the editor settings.

Sure. http://forum.confederali...osts/t1-Testing-Settings

No one is using the forum yet. So if you would like to take a look use credentials:

Username: YAFadmin
Password: 1a2b3c

It really is a plain jane setup with the So Clean theme.
Offline tha_watcha  
#4 Posted : Monday, September 18, 2017 6:38:21 AM(UTC)
tha_watcha


Rank: YAF.NET Project Lead

Reputation:

Medals: Medal of Honor: Portal Puzzle Master: Portal Puzzle Master for DNNMedal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.DNN Master: DNN Module ManBug Killer Medal of Honor: Medal for being a kick-ass bug killer!Medal of Honor for the Support King: Support King! Amazing asset to the YAF.NET Community.

Joined: 3/6/2010(UTC)
Posts: 3,743
Germany

Thanks: 70 times
Was thanked: 1149 time(s) in 979 post(s)
Yes at the moment on a Mobile Device the Standard BBCode editor is forced, because really the other editors like CKEditor are not really suitable for mobile devices (but its getting better)

Quote:
No one is using the forum yet. So if you would like to take a look use credentials:


Looks like the password is wrong. and really is better you send it to me via PM.
Offline tha_watcha  
#5 Posted : Thursday, September 21, 2017 7:22:41 AM(UTC)
tha_watcha


Rank: YAF.NET Project Lead

Reputation:

Medals: Medal of Honor: Portal Puzzle Master: Portal Puzzle Master for DNNMedal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.DNN Master: DNN Module ManBug Killer Medal of Honor: Medal for being a kick-ass bug killer!Medal of Honor for the Support King: Support King! Amazing asset to the YAF.NET Community.

Joined: 3/6/2010(UTC)
Posts: 3,743
Germany

Thanks: 70 times
Was thanked: 1149 time(s) in 979 post(s)
thanks for the PM. This needs some further testing.

The problem here is in when you edit a posting, that was before written as html message with an html editor. And next because you're on a mobile device you edit the post with an BBCode editor the posting is automatically converted from html to bbcode.

Which should work in most cases by my converter. This should also work in the other direction. from BBCode to HTML.

I do more testing in the next days to optimize the converter, and this will be hopefully fixed in 2.2.4.3
Offline tha_watcha  
#6 Posted : Saturday, September 30, 2017 9:47:49 AM(UTC)
tha_watcha


Rank: YAF.NET Project Lead

Reputation:

Medals: Medal of Honor: Portal Puzzle Master: Portal Puzzle Master for DNNMedal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.DNN Master: DNN Module ManBug Killer Medal of Honor: Medal for being a kick-ass bug killer!Medal of Honor for the Support King: Support King! Amazing asset to the YAF.NET Community.

Joined: 3/6/2010(UTC)
Posts: 3,743
Germany

Thanks: 70 times
Was thanked: 1149 time(s) in 979 post(s)
Okay this issue will be improved it still needs some work put at least the paragraphs will not lost when converting.

Also i removed in YAF 2.2.4.4 the override of the editor when using a mobile device.
Rss Feed  Atom Feed
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Notification

Icon
Error