Welcome Guest! To enable all features please Login or Register.
Options
View
Go to last post Go to first unread
Offline filtergraph  
#1 Posted : Monday, October 9, 2017 3:19:49 PM(UTC)
filtergraph


Rank: YAF Forumling

Reputation:

Joined: 10/9/2017(UTC)
Posts: 3
United States

I have installed YAF on a server with iis 7. The installation went okay but I cannot click any any links without getting a 404 error. At first I thought I had no access to the pages directory but I ruled that out by adding an html page and calling it with ~/pages/test.html. I have to insert the pages directory in the url or I get a 404 error. I cannot insert the pages directory into the url for other pages withouth getting a 404 error. So my thoughts are that there is a configuration missing or something configured incorrectly.

Does anyone know why this is happening?

Thanks in advance.
Sponsor
Offline tha_watcha  
#2 Posted : Tuesday, October 10, 2017 2:50:55 AM(UTC)
tha_watcha


Rank: YAF.NET Project Lead

Reputation:

Medals: Medal of Honor: Portal Puzzle Master: Portal Puzzle Master for DNNMedal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.DNN Master: DNN Module ManBug Killer Medal of Honor: Medal for being a kick-ass bug killer!Medal of Honor for the Support King: Support King! Amazing asset to the YAF.NET Community.

Joined: 3/6/2010(UTC)
Posts: 3,743
Germany

Thanks: 70 times
Was thanked: 1149 time(s) in 979 post(s)
Do you mean the links inside the forum didn't work, or other urls from your site?

The problem is that all urls are handled via the urlrewriter. in your case you need to open the urlrewriter.config and change the line...

Code:
  <if url="^((?!\.ashx|\.asmx|\.axd|\.gif|\.png|\.jpg|\.ico|\.pdf|\.css|\.js|\/install|error\.aspx|auth\.aspx|default\.aspx|popup\.aspx|advanced\.aspx|digest\.aspx|ftb.imagegallery\.aspx|ckfinder).)*$">


to...

Code:
  <if url="^((?!\.ashx|\.asmx|\.axd|\.gif|\.png|\.jpg|\.ico|\.pdf|\.css|\.js|\/install|error\.aspx|auth\.aspx|default\.aspx|popup\.aspx|advanced\.aspx|digest\.aspx|ftb.imagegallery\.aspx|ckfinder|\/pages).)*$">



Offline filtergraph  
#3 Posted : Tuesday, October 10, 2017 9:38:43 AM(UTC)
filtergraph


Rank: YAF Forumling

Reputation:

Joined: 10/9/2017(UTC)
Posts: 3
United States

YAF is the website. I have not added it to another site.

It may have something to do with the server I was using (What, I do not know). I moved the YAF site to a different server and all is working.
Offline Hyabusact  
#4 Posted : Sunday, November 19, 2017 12:12:46 PM(UTC)
Hyabusact


Rank: YAF Forumling

Reputation:

Joined: 11/19/2017(UTC)
Posts: 3
United States
Location: CT

I am getting the same error but I cant move this to another site. When you click onto the forum it errors, when you click to log in, it errors and if you try to register it will error. All 404 errors. Any help?
Offline tha_watcha  
#5 Posted : Sunday, November 19, 2017 11:26:00 PM(UTC)
tha_watcha


Rank: YAF.NET Project Lead

Reputation:

Medals: Medal of Honor: Portal Puzzle Master: Portal Puzzle Master for DNNMedal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.DNN Master: DNN Module ManBug Killer Medal of Honor: Medal for being a kick-ass bug killer!Medal of Honor for the Support King: Support King! Amazing asset to the YAF.NET Community.

Joined: 3/6/2010(UTC)
Posts: 3,743
Germany

Thanks: 70 times
Was thanked: 1149 time(s) in 979 post(s)
Does it work when you disable url rewriting

Code:
<add key="YAF.EnableURLRewriting" value="false" />

Edited by user Monday, November 20, 2017 9:19:27 PM(UTC)  | Reason: Not specified

Offline Hyabusact  
#6 Posted : Monday, November 20, 2017 5:06:48 PM(UTC)
Hyabusact


Rank: YAF Forumling

Reputation:

Joined: 11/19/2017(UTC)
Posts: 3
United States
Location: CT

To the Web.config file?
Offline Hyabusact  
#7 Posted : Monday, November 20, 2017 5:14:19 PM(UTC)
Hyabusact


Rank: YAF Forumling

Reputation:

Joined: 11/19/2017(UTC)
Posts: 3
United States
Location: CT

When I add that to the Web.config file, the site will not run.
Offline tha_watcha  
#8 Posted : Monday, November 20, 2017 9:21:17 PM(UTC)
tha_watcha


Rank: YAF.NET Project Lead

Reputation:

Medals: Medal of Honor: Portal Puzzle Master: Portal Puzzle Master for DNNMedal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.DNN Master: DNN Module ManBug Killer Medal of Honor: Medal for being a kick-ass bug killer!Medal of Honor for the Support King: Support King! Amazing asset to the YAF.NET Community.

Joined: 3/6/2010(UTC)
Posts: 3,743
Germany

Thanks: 70 times
Was thanked: 1149 time(s) in 979 post(s)
Sorry I forgot to mention you need to add it to the app.config
Rss Feed  Atom Feed
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Notification

Icon
Error