Foil
  • Posts: 4
  • Joined: 13/06/2018
Hi!

Due to some unfortunate circumstances (our webserver admin recently passed away + a drive crash and subsequent OS reinstall), I'm looking to re-install a YAF v2.2.0 forum on my team's webserver.

I'm an application developer (C++), but I'm not very experienced in this area. I have some networking knowledge, and I know a little about IIS configuration, but my experience setting up db connections is fairly limited. I'm thinking I may need to post here from time to time as I get it set up, so thank you in advance for any assistance as I get through this.

Anyway, here's my first hurdle:

According to the installation wiki ( https://github.com/YAFNET/YAFNET/wiki/Installation  ), YAF requires Win Server 2008. But our webserver (including the old YAF forum) has always run on Win Server 2003 SBS SP2. I confirmed the YAF version by visiting an archived copy of our top page: https://web.archive.org/...tp://rbb.ripteam.com:80/ 

Is there something I'm misunderstanding about the version or requirements (WS2008 vs. WS2003), or is it possible our now-deceased admin did some kind of custom work to get YAF v2.2.0 to run on Server 2003?
Sponsor
tha_watcha
  • Posts: 4133
  • Joined: 06/03/2010
The current version needs net 4.5.2 which doesn't work with Windows Server 2003, only 2008 or higher. The yaf version you are using uses net 4.0 which runs on windows Server 2003. So it should work on your server.
UserPostedImage
Foil
  • Posts: 4
  • Joined: 13/06/2018
Ah, thank you for the clarification!

A couple of quick questions, as I get into this:

* Are there any major differences I should be aware of, between the installation of v2.2.0 and the notes in the current installation wiki?

* Since I have access to the previous db and previous YAF installation folder (it seems to have been unimpacted by the drive crash), would you recommend a copy-and-fix-up-the-db-connection approach, or a clean install?
tha_watcha
  • Posts: 4133
  • Joined: 06/03/2010
Originally Posted by: Foil 


* Are there any major differences I should be aware of, between the installation of v2.2.0 and the notes in the current installation wiki?



No the installation is the same

Originally Posted by: Foil 


* Since I have access to the previous db and previous YAF installation folder (it seems to have been unimpacted by the drive crash), would you recommend a copy-and-fix-up-the-db-connection approach, or a clean install?



If the old database is okay then you should connect to your old forum installation.


UserPostedImage
Foil
  • Posts: 4
  • Joined: 13/06/2018
Thank you! I'll post again when I've had some time to work on this.
Foil
  • Posts: 4
  • Joined: 13/06/2018
[Apologies for the long bump.]

Unfortunately, I haven't managed to devote any significant time to this. Honestly, when I tried looking into it, I didn't get far.

Is there someone here who would be willing to devote a couple hours to remotely work on it? I can pay for the time, rate negotiable, probably no more than 2-3 hours.
[Admins, let me know if I'm breaking any rules here.]
Users browsing this topic
    Forum Jump  
    • You cannot post new topics in this forum.
    • You cannot reply to topics in this forum.
    • You cannot delete your posts in this forum.
    • You cannot edit your posts in this forum.
    • You cannot create polls in this forum.
    • You cannot vote in polls in this forum.

    About Us

    The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

    Powered by Resharper Donate with PayPal button

    Project Twitter Updates

    Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved