Welcome Guest! To enable all features please Login or Register.
2 Pages<12
Options
View
Go to last post Go to first unread
Offline bbobb  
#31 Posted : Wednesday, October 6, 2010 2:42:27 PM(UTC)
bbobb


Rank: YAF Developer

Reputation:

Medals: Medal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.Medal of Honor for a YAF Database Key Player: Holds the key to YAF database. Bow down!Medal of Honor for the Support King: Given for answering tons of support questions and generally helping the community.Medal of Honor for the Support Knight: Given to a community member who has answered lots of support questions.

Joined: 10/21/2008(UTC)
Posts: 1,558
Man
Russian Federation
Location: Moscow

Thanks: 51 times
Was thanked: 288 time(s) in 254 post(s)
1. I can't see mobile theme in release notes. This means that it doesn't available.
2. You can use rss feeds for topics to "subscribe" otherwise you should check your host settings for new items. It's quite possible that it's disabled.

Quote:
Another problem I ran into is that ajax does not work properly under FF and Chrome (IE seems to be OK) on themes that do not use CSS3 (rounded corners)

A fuzzy report.
Offline Underground  
#32 Posted : Thursday, October 7, 2010 12:17:23 AM(UTC)
Underground


Rank: YAF Commander

Reputation:

Joined: 6/4/2009(UTC)
Posts: 103

Thanks: 18 times
Was thanked: 8 time(s) in 8 post(s)
bbobb wrote:
1. I can't see mobile theme in release notes. This means that it doesn't available.
2. You can use rss feeds for topics to "subscribe" otherwise you should check your host settings for new items. It's quite possible that it's disabled.

Quote:
Another problem I ran into is that ajax does not work properly under FF and Chrome (IE seems to be OK) on themes that do not use CSS3 (rounded corners)

A fuzzy report.

About the mobile theme. OK, but it says RC1 (so release candidate) and I assumed that everything that is available within the build is supposed to be working. But I guess it is a alpha/beta build as some parts are known not to be in a working state. No problem though.

Regarding the missing email notification: nope.
I have made notification active on threads within this forum and I don't get any emails when posst are added.
But also not on my testsite. I always got notification emails (as part of the tests). But after I installed the 195RC1 the test failed.

And now more about the fuzzy report Wink
When I select the YafVision theme and go to the main forum page. Everything is OK. You see after loading the page, there is one ajax call after a sec or so and it finishes.
But, when I choose one of the color-color themes (I guess CCS3 theme with rounded corners and shading) and I go to the main forum page. I see that after a second or two the ajax call is made, but it doesn't finish. I am running it in a masterpage where I inform the user when a ajax request (ajax page update) is done (like google in gmail is doing). However, the message never disappears. This tells me that the ajax call has blocked.
Also, after that, I cannot perform any other ajax call like opening a panel (lets say shoutbox). All is blocked. I can only request anouther page.
All wens OK in IE, so in IE there wasn't a problem. Only FF and Chrome had this issue.

Hope it is less fuzzy now Wink

For me, the missing email notification is a showstopper for using the new release (candidate)
The themes that causes problems, I can remove them.

However, one thing I really was excited about was the language editor. Great tool!
Now, after the showstopper has been solved, I will translate all and upload the new Dutch language resource file.

- Robert

Edited by user Thursday, October 7, 2010 12:18:53 AM(UTC)  | Reason: Not specified

My site containing the YAF forum: Globalcaching.eu
Offline f0zzyNUE  
#33 Posted : Thursday, October 7, 2010 12:32:51 AM(UTC)
f0zzyNUE


Rank: YAF Commander

Reputation:

Joined: 9/9/2010(UTC)
Posts: 89

Thanks: 34 times
Was thanked: 2 time(s) in 2 post(s)
I can confirm the fuzzy report - on Safari ...
thanks 1 user thanked f0zzyNUE for this useful post.
Underground on 10/7/2010(UTC)
Offline mortengr  
#34 Posted : Thursday, October 7, 2010 2:28:18 AM(UTC)
mortengr


Rank: YAF Forumling

Reputation:

Joined: 10/7/2010(UTC)
Posts: 5

Hello.

I think i have encountered a bug with v1.9.5 RC1, under certain circumstances.

Problem
When changing the .Net target framework to 4.0, the files with DNA prefix requires full trust instead of medium trust. The implication is that the admin panel will no longer be accessible, because YAF fails with the following message when running in an environment restricted to medium trust:

--

UserPostedImage

--

Recreating the problem
To recreate the problem follow these steps:
1) Download the YAF Source v1.9.5
2) Copy the recommended web.config to the root and setup the DB connection string
3) Add the line <trust level="Medium"/> to the web.config
4) Go to properties for YAF and set the target framework to 4.0
5) Add a reference to System.Servicemodel and delete the databaseextensions reference no longer working.

Besides the trust issue, every other component seems to work when running .Net 4.0. If I switch back to 3.5, even after I have added the servicemodel reference and deleted databaseextensions, the adminpanel is accessible again.

Fix
I have done some attempts to solve the issue, but with no luck. I suspect that the DNA files are signed in .net 3.5, and somehow loose this signing when switching to .net 4.0, then requiring full trust - but this is just a wild guess.

I hope this gets solved. Since my webpage runs asp 4.0 I need the forum to work with this framework as well.

- Morten

Edited by user Thursday, October 7, 2010 2:42:23 AM(UTC)  | Reason: Not specified

Offline tha_watcha  
#35 Posted : Thursday, October 7, 2010 4:48:51 AM(UTC)
tha_watcha


Rank: YAF.NET Project Lead

Reputation:

Medals: Medal of Honor: Portal Puzzle Master: Portal Puzzle Master for DNNMedal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.DNN Master: DNN Module ManBug Killer Medal of Honor: Medal for being a kick-ass bug killer!Medal of Honor for the Support King: Support King! Amazing asset to the YAF.NET Community.

Joined: 3/6/2010(UTC)
Posts: 3,736
Germany

Thanks: 70 times
Was thanked: 1149 time(s) in 979 post(s)
Quote:
When I select the YafVision theme and go to the main forum page. Everything is OK. You see after loading the page, there is one ajax call after a sec or so and it finishes.
But, when I choose one of the color-color themes (I guess CCS3 theme with rounded corners and shading) and I go to the main forum page. I see that after a second or two the ajax call is made, but it doesn't finish. I am running it in a masterpage where I inform the user when a ajax request (ajax page update) is done (like google in gmail is doing). However, the message never disappears. This tells me that the ajax call has blocked.


I think i found the problem, the Js Code was not correctly.
thanks 2 users thanked tha_watcha for this useful post.
Underground on 10/7/2010(UTC), f0zzyNUE on 10/10/2010(UTC)
Offline doxa123  
#36 Posted : Thursday, October 7, 2010 2:12:24 PM(UTC)
doxa123


Rank: YAF All-the-Time

Reputation:

Joined: 9/28/2009(UTC)
Posts: 170
Man
Turkey
Location: istanbul

Thanks: 62 times
Was thanked: 8 time(s) in 6 post(s)
This changes everything. Again Smile
Running YAF.NET v2.0 Final at: http://www.dilliduduk.com
.net 4.5.1 & MVC 5 Razor Support Hosting: http://hosting.7renk.net
Offline ninaxd  
#37 Posted : Monday, October 11, 2010 6:17:16 AM(UTC)
ninaxd


Rank: YAF Camper

Reputation:

Medals: YAF.NET Supporter: Loves YAF.NET!YAF.NET Red Supporter: Thank you Nina for supporting YAF.NET!YAF.NET Supporter: Supports our efforts. Thank you.

Joined: 4/10/2010(UTC)
Posts: 24

Thanks: 6 times
Was thanked: 1 time(s) in 1 post(s)
Jaben wrote:
f0zzyNUE wrote:
tommy382 wrote:
Anyone tried upgrading from 1.9.4Final yet? Will the install script knows about the upgrade or I have to run a different "upgrade installer"?

i have done that successfully ... unfortunately my favorite theme "flat earth" is no longer available Angry

Some themes had to go -- I don't have the resources to support so many themes during changes and modifications.

I would bring it back if anyone was willing to support it.


I will support the themes - I had a look at them today - I LOVE YETANOTHERFORUM. If you tell me what I need to do I'll make sure I keep them up to date.
I also played around with the Latest Forums css file as it was a bit big for me - and added another class to it and modified the ascx file so and put some span styling between the ( opening and closing ) brackets that were a bit disjointed.

Nina
Offline f0zzyNUE  
#38 Posted : Tuesday, October 12, 2010 2:41:30 PM(UTC)
f0zzyNUE


Rank: YAF Commander

Reputation:

Joined: 9/9/2010(UTC)
Posts: 89

Thanks: 34 times
Was thanked: 2 time(s) in 2 post(s)
is there any timeline for 1.9.5 final and v2.0 ?

we really need a better implementation for the active topics view (e.g. link to last unread post instead of last post). i am at a desicion point where i need to know whether it is worth waiting for the upcoming release or whether i should implement that feature myself.
Offline tommy382  
#39 Posted : Wednesday, October 13, 2010 12:29:23 PM(UTC)
tommy382


Rank: YAF Commander

Reputation:

Joined: 4/11/2008(UTC)
Posts: 91

Thanks: 10 times
Was thanked: 3 time(s) in 3 post(s)
f0zzyNUE wrote:
is there any timeline for 1.9.5 final and v2.0 ?

we really need a better implementation for the active topics view (e.g. link to last unread post instead of last post). i am at a desicion point where i need to know whether it is worth waiting for the upcoming release or whether i should implement that feature myself.

That one is very useful. Is that something that will be implemented in 1.9.5Final?
Offline f0zzyNUE  
#40 Posted : Wednesday, October 13, 2010 3:15:25 PM(UTC)
f0zzyNUE


Rank: YAF Commander

Reputation:

Joined: 9/9/2010(UTC)
Posts: 89

Thanks: 34 times
Was thanked: 2 time(s) in 2 post(s)
tommy382 wrote:
f0zzyNUE wrote:
is there any timeline for 1.9.5 final and v2.0 ?

we really need a better implementation for the active topics view (e.g. link to last unread post instead of last post). i am at a desicion point where i need to know whether it is worth waiting for the upcoming release or whether i should implement that feature myself.

That one is very useful. Is that something that will be implemented in 1.9.5Final?


from the bugtracking system i saw that the milestone for that feature is v2.0 - or am i mistaken?
Offline TommyB  
#41 Posted : Tuesday, October 19, 2010 5:50:56 PM(UTC)
TommyB


Rank: YAF Commander

Reputation:

Joined: 7/6/2005(UTC)
Posts: 118

Thanks: 1 times
Was thanked: 1 time(s) in 1 post(s)
Is it possible now to create more than one forum with the same name?
- Sry for my english Wink

BattCursor.Net - Official homepage of that tool for vista laptops!
Offline Arloth  
#42 Posted : Tuesday, December 7, 2010 3:10:28 AM(UTC)
Arloth


Rank: YAF Forumling

Reputation:

Joined: 12/6/2010(UTC)
Posts: 1

Hey everyone, i am pretty impressed by the work you have done on this project really a great work. I have installed the application from install.aspx but i need to make some changes/tweaks so i need to publish the project but i got error when i try to publish, really appreciate if you can help me.

here are the steps what i have done and what i got.

1- downloaded YAF-v1.9.5-RC1-SRC.zip
2- a opened visual studio 2010, file -> open web site -> selected yetAnotherForum.NET folder
UserPostedImage
2 - b - Solution Window/// screenshot -> UserPostedImage
3- added line <trust level="Medium"/> after <configSections>...</configSections> to web.config
UserPostedImage
4- clicked on YAF properties it was framework 4.0 seleceted so did nothing on this step.
UserPostedImage
Uploaded with ImageShack.us
5- added reference system.servicemodel from .net tab

6- build the solution got error, unrecognized configuration section thrust
UserPostedImage
Info: I am using visual studio 2010, sql server 2008 and trying to use the framework 4.0 version of YAF as you can see.

By the way apart from this, when i need to publish YAF do i need to open solution yetanotherforum.net-2010.sln or will it be ok if i open visual studio 2010, file -> open web site -> selected yetAnotherForum.NET folder?
Offline bbobb  
#43 Posted : Tuesday, December 7, 2010 4:35:47 AM(UTC)
bbobb


Rank: YAF Developer

Reputation:

Medals: Medal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.Medal of Honor for a YAF Database Key Player: Holds the key to YAF database. Bow down!Medal of Honor for the Support King: Given for answering tons of support questions and generally helping the community.Medal of Honor for the Support Knight: Given to a community member who has answered lots of support questions.

Joined: 10/21/2008(UTC)
Posts: 1,558
Man
Russian Federation
Location: Moscow

Thanks: 51 times
Was thanked: 288 time(s) in 254 post(s)
Use 1.9.5 RTW it has bug fixes.
Offline tha_watcha  
#44 Posted : Tuesday, December 7, 2010 5:22:09 AM(UTC)
tha_watcha


Rank: YAF.NET Project Lead

Reputation:

Medals: Medal of Honor: Portal Puzzle Master: Portal Puzzle Master for DNNMedal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.DNN Master: DNN Module ManBug Killer Medal of Honor: Medal for being a kick-ass bug killer!Medal of Honor for the Support King: Support King! Amazing asset to the YAF.NET Community.

Joined: 3/6/2010(UTC)
Posts: 3,736
Germany

Thanks: 70 times
Was thanked: 1149 time(s) in 979 post(s)
Quote:
I am using visual studio 2010, sql server 2008 and trying to use the framework 4.0 version of YAF as you can see.


Please do NOT use YAF with .NET 4 and Medium Trust, use .NET 3.5 instead. And use 1.9.5 Final as bbobb wrotes:

http://yafnet.codeplex.com/releases/view/55834
Offline bslt24  
#45 Posted : Wednesday, January 5, 2011 9:40:02 PM(UTC)
bslt24


Rank: YAF Forumling

Reputation:

Joined: 3/31/2010(UTC)
Posts: 3

Thank guys, I like YAF a long time, and now i have just opportunity to try it's...

Edited by user Wednesday, January 5, 2011 9:41:37 PM(UTC)  | Reason: Not specified

Rss Feed  Atom Feed
Users browsing this topic
2 Pages<12
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Notification

Icon
Error