binhchau
  • Posts: 19
  • Joined: 15/12/2008
I want to upgrade YAF from version 1.9.3 to 1.9.5 but keeping old database of YAF 1.9.3. Although I did it many times, I can't login after upgrading it. It appears an error: "Wrong password". Who can help me? Thanks so much!
Sponsor
squirrel
  • Posts: 925
  • Joined: 14/01/2010
Originally Posted by: binhchau 

I want to upgrade YAF from version 1.9.3 to 1.9.5 but keeping old database of YAF 1.9.3. Although I did it many times, I can't login after upgrading it. It appears an error: "Wrong password". Who can help me? Thanks so much!



I think what you're going to need to do is to run the installer. It upgrades a database, not deletes it. When YAF detects an existing database, it upgrades it. Otherwise, it creates fresh tables.

If you want, and you have backups, I can assist with upgrade, although it is pretty straight forward process.

All you need to do is go to (forum url)/install/default.aspx, enter in your config password and let YAF do it's thing. Again, if you want, I can assist.

If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
binhchau
  • Posts: 19
  • Joined: 15/12/2008
Thanks for your help. I did the same as you told. I run /install/default.aspx, enter in your config password, then I finished and came to the forum but I can't login. I don't know the reason.
Dr-Hack
  • Posts: 160
  • Joined: 31/12/2004
Delete it cant actually , you will be able to see that in your database all forum data is preserved as it is .. try a "Forget your Pass" ? it might mail it to you .. ?
squirrel
  • Posts: 925
  • Joined: 14/01/2010
Originally Posted by: Dr-Hack 

Delete it cant actually , you will be able to see that in your database all forum data is preserved as it is .. try a "Forget your Pass" ? it might mail it to you .. ?



That's a good suggestion. The system should be able to mail/reset his password - what bothers me is that 99.9% of the time if you can't login after an upgrade, it has to do with the membership settings. I don't know if his database dates back prior to 1.9.1 or if it started as 1.9.3 -- In the first posts, it was an upgrade from 1.9.1 to 1.9.3 and so that's why I made note that the membership had to be changed. Then, later in the help, it was an upgrade from 1.9.3 to 1.9.5 - so there's a real up-in-the-air issue here.

Because the forum is in a language that barely translates for me, it's hard for me to test and diagnose.

He wasn't getting a ASP.NET error -- but whenever you try to login, it accepts the username and password, then dies with the yaf internal error "An error has occurred" and redirects to the forum root. With customErrors turned off, it still does this, and doesn't throw an exception - so it's an error that yaf is catching and logging.

There's a chance browsing the database for the YAF event errors might reveal something, but I'm not sure.
If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
tha_watcha
  • Posts: 4133
  • Joined: 06/03/2010
No that error message will be still popup, when there is something wrong with the Membership

My question is did you modified the source code, because it looks like it? And why 1.95 RC 1 and not 1.9.5.5?
UserPostedImage
binhchau
  • Posts: 19
  • Joined: 15/12/2008
Here is link from my source: http://yetanotherforum.net/download.aspx . And I see this version: 1.9.5 RC1. I just traslated it into Vietnamese. If you don't mind, I can upload my database from this version.
squirrel
  • Posts: 925
  • Joined: 14/01/2010
Originally Posted by: binhchau 

Here is link from my source: http://yetanotherforum.net/download.aspx . And I see this version: 1.9.5 RC1. I just traslated it into Vietnamese. If you don't mind, I can upload my database from this version.



The latest "Official" release was 1.9.5.5 -- the current BETA release is 1.9.6 RC1 - the version you're running is quite old.

But considering you're currently having problems, upgrading further I don't think will fix them. I still think it's a membership issue, but I can't get much further than that. Somewhere something is having problems between last version and this one. Did you make backup of old version before you uploaded the new version to it? (not the database but the forum) --


If you can't find it using the forum search, try my signature link -- searches this site using Google: Google is my Friend 
tha_watcha
  • Posts: 4133
  • Joined: 06/03/2010
Originally Posted by: binhchau 

Here is link from my source: http://yetanotherforum.net/download.aspx . And I see this version: 1.9.5 RC1. I just traslated it into Vietnamese. If you don't mind, I can upload my database from this version.



How big is the db? If its ok put it in a zip file and upload the db and send me the download link via Private Message or Email do NOT post it here in the forum. And i can try your db via debugging to find the problem
UserPostedImage
Users browsing this topic
    Forum Jump  
    • You cannot post new topics in this forum.
    • You cannot reply to topics in this forum.
    • You cannot delete your posts in this forum.
    • You cannot edit your posts in this forum.
    • You cannot create polls in this forum.
    • You cannot vote in polls in this forum.

    About Us

    The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

    Powered by Resharper Donate with PayPal button

    Project Twitter Updates

    Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved