Welcome Guest! To enable all features please Login or Register.
2 Pages<12
Options
View
Go to last post Go to first unread
Offline trumso  
#16 Posted : Wednesday, May 13, 2015 8:50:55 AM(UTC)
trumso


Rank: YAF Camper

Reputation:

Joined: 5/2/2015(UTC)
Posts: 22
United States

Thanks: 10 times
Originally Posted by: Zero2Cool Go to Quoted Post

Add this to the very top of you theme.css file in the /themes/YafVision/ directory.

Code:
.yafnet
{
	background-color: #008800;
}


If it worked, you'll see green in the background.


Yes, it worked smoothly, but I mean this background Cheesy Grin
Sorry for any confusing.

UserPostedImage

Offline Zero2Cool  
#17 Posted : Wednesday, May 13, 2015 8:52:11 AM(UTC)
Zero2Cool


Rank: YAF Leader

Reputation:

Medals: Medal of Honor for the Support Knight: Given to a community member who has assisted lots and lots of people!

Joined: 4/26/2011(UTC)
Posts: 1,062
Man
United States
Location: in a van down by the river

Thanks: 234 times
Was thanked: 101 time(s) in 92 post(s)
Originally Posted by: trumso Go to Quoted Post
Originally Posted by: Zero2Cool Go to Quoted Post

Add this to the very top of you theme.css file in the /themes/YafVision/ directory.

Code:
.yafnet
{
	background-color: #008800;
}


If it worked, you'll see green in the background.


Yes, it worked smoothly, but I mean this background Cheesy Grin
Sorry for any confusing.

UserPostedImage



Are you running YAF by itself or within another environment such as DotNetNuke or maybe your own ASP.NET program? Do you have the site online?

Offline trumso  
#18 Posted : Wednesday, May 13, 2015 9:19:21 AM(UTC)
trumso


Rank: YAF Camper

Reputation:

Joined: 5/2/2015(UTC)
Posts: 22
United States

Thanks: 10 times
Yes, Zero2Cool. It's still testing.

http://mvatoi-001-site1....terasp.net/testingforum/
Offline Zero2Cool  
#19 Posted : Wednesday, May 13, 2015 9:45:18 AM(UTC)
Zero2Cool


Rank: YAF Leader

Reputation:

Medals: Medal of Honor for the Support Knight: Given to a community member who has assisted lots and lots of people!

Joined: 4/26/2011(UTC)
Posts: 1,062
Man
United States
Location: in a van down by the river

Thanks: 234 times
Was thanked: 101 time(s) in 92 post(s)
Originally Posted by: trumso Go to Quoted Post
Yes, Zero2Cool. It's still testing.

http://mvatoi-001-site1....terasp.net/testingforum/



Remember where you added that last snippet of CSS? Add , body like below and that'll make the whole thing Green.

Code:
.yafnet, body {
  background-color: #008800;
}
thanks 1 user thanked Zero2Cool for this useful post.
trumso on 5/13/2015(UTC)
Offline trumso  
#20 Posted : Wednesday, May 13, 2015 10:15:04 AM(UTC)
trumso


Rank: YAF Camper

Reputation:

Joined: 5/2/2015(UTC)
Posts: 22
United States

Thanks: 10 times
Originally Posted by: Zero2Cool Go to Quoted Post

Remember where you added that last snippet of CSS? Add , body like below and that'll make the whole thing Green.

Code:
.yafnet, body {
  background-color: #008800;
}


wow it's working perfectly.
Many thanks.
Offline trumso  
#21 Posted : Friday, May 15, 2015 1:53:08 PM(UTC)
trumso


Rank: YAF Camper

Reputation:

Joined: 5/2/2015(UTC)
Posts: 22
United States

Thanks: 10 times
Hello Zero2Cool,
Could you please teach me how I can center YAF.NET forum? I used your code which you posted before and add on the top of theme.css but it didn't word. Thanks

Code:
.ctr {
    margin-left: auto;
    margin-right: auto;
}
Offline Zero2Cool  
#22 Posted : Friday, May 15, 2015 1:56:03 PM(UTC)
Zero2Cool


Rank: YAF Leader

Reputation:

Medals: Medal of Honor for the Support Knight: Given to a community member who has assisted lots and lots of people!

Joined: 4/26/2011(UTC)
Posts: 1,062
Man
United States
Location: in a van down by the river

Thanks: 234 times
Was thanked: 101 time(s) in 92 post(s)
Originally Posted by: trumso Go to Quoted Post
Hello Zero2Cool,
Could you please teach me how I can center YAF.NET forum? I used your code which you posted before and add on the top of theme.css but it didn't word. Thanks

Code:
.ctr {
    margin-left: auto;
    margin-right: auto;
}


You have to wrap a <div class="ctr"> </div> around your YAF forum in the default.aspx page.
thanks 1 user thanked Zero2Cool for this useful post.
trumso on 5/15/2015(UTC)
Offline trumso  
#23 Posted : Friday, May 15, 2015 5:13:25 PM(UTC)
trumso


Rank: YAF Camper

Reputation:

Joined: 5/2/2015(UTC)
Posts: 22
United States

Thanks: 10 times
Thanks, Zero2Cool,
Here is my code following your instruction but it doesn't work.

Code:
<%@ Page Language="C#" AutoEventWireup="true" ValidateRequest="false" Inherits="YAF.ForumPageBase" %>
<%@ Register TagPrefix="YAF" Assembly="YAF" Namespace="YAF" %>
<script runat="server">
	
</script>
<div class="ctr">
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head id="YafHead" runat="server">
    <meta id="YafMetaScriptingLanguage" http-equiv="Content-Script-Type" runat="server"
        name="scriptlanguage" content="text/javascript" />
    <meta id="YafMetaStyles" http-equiv="Content-Style-Type" runat="server" name="styles"
        content="text/css" />
    <meta id="YafMetaDescription" runat="server" name="description" content="Yet Another Forum.NET -- A bulletin board system written in ASP.NET" />
    <meta id="YafMetaKeywords" runat="server" name="keywords" content="Yet Another Forum.net, Forum, ASP.NET, BB, Bulletin Board, opensource" />
    <meta name="HandheldFriendly" content="true"/>
    <meta name="viewport" content="width=device-width,user-scalable=yes"/>
    <title></title>
</head>
<body style="margin: 0; padding: 5px">
    <asp:HyperLink runat="server" id="BannerLink" >
        <img src="~/forumlogo.gif" runat="server" alt="logo" style="border: 0;" id="imgBanner" />
    </asp:HyperLink>
    <br />
    <form id="form1" runat="server" enctype="multipart/form-data">
    <YAF:Forum runat="server" ID="forum" BoardID="1">
    </YAF:Forum>
    </form>
</body>
</html>
</div>


Code:
.ctr {
    margin-left: auto;
    margin-right: auto;
}

/* Change forum's background color */
.yafnet, body {
  background-color: #E0FFFF; 
}

.yafnet .EditorDiv td
{
    padding: 0 !important;
    border: 0 !important;
}
Offline Zero2Cool  
#24 Posted : Friday, May 15, 2015 5:22:01 PM(UTC)
Zero2Cool


Rank: YAF Leader

Reputation:

Medals: Medal of Honor for the Support Knight: Given to a community member who has assisted lots and lots of people!

Joined: 4/26/2011(UTC)
Posts: 1,062
Man
United States
Location: in a van down by the river

Thanks: 234 times
Was thanked: 101 time(s) in 92 post(s)
Originally Posted by: trumso Go to Quoted Post
Thanks, Zero2Cool,
Here is my code following your instruction but it doesn't work.

Code:
<%@ Page Language="C#" AutoEventWireup="true" ValidateRequest="false" Inherits="YAF.ForumPageBase" %>
<%@ Register TagPrefix="YAF" Assembly="YAF" Namespace="YAF" %>
<script runat="server">
	
</script>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head id="YafHead" runat="server">
    <meta id="YafMetaScriptingLanguage" http-equiv="Content-Script-Type" runat="server"
        name="scriptlanguage" content="text/javascript" />
    <meta id="YafMetaStyles" http-equiv="Content-Style-Type" runat="server" name="styles"
        content="text/css" />
    <meta id="YafMetaDescription" runat="server" name="description" content="Yet Another Forum.NET -- A bulletin board system written in ASP.NET" />
    <meta id="YafMetaKeywords" runat="server" name="keywords" content="Yet Another Forum.net, Forum, ASP.NET, BB, Bulletin Board, opensource" />
    <meta name="HandheldFriendly" content="true"/>
    <meta name="viewport" content="width=device-width,user-scalable=yes"/>
    <title></title>
</head>
<body style="margin: 0; padding: 5px">
    <asp:HyperLink runat="server" id="BannerLink" >
        <img src="~/forumlogo.gif" runat="server" alt="logo" style="border: 0;" id="imgBanner" />
    </asp:HyperLink>
    <br />
    <form id="form1" runat="server" enctype="multipart/form-data">
    <YAF:Forum runat="server" ID="forum" BoardID="1">
    </YAF:Forum>
    </form>
</body>
</html>
</div>


Code:
.ctr {
    margin-left: auto;
    margin-right: auto;
}

/* Change forum's background color */
.yafnet, body {
  background-color: #E0FFFF; 
}

.yafnet .EditorDiv td
{
    padding: 0 !important;
    border: 0 !important;
}


Check out line 30ish...
Code:
<div class="ctr">
<YAF:Forum runat="server" ID="forum" BoardID="1"></YAF:Forum>
</div>
thanks 1 user thanked Zero2Cool for this useful post.
trumso on 5/15/2015(UTC)
Offline trumso  
#25 Posted : Friday, May 15, 2015 9:56:35 PM(UTC)
trumso


Rank: YAF Camper

Reputation:

Joined: 5/2/2015(UTC)
Posts: 22
United States

Thanks: 10 times
Thank you so much.
Maybe I do something wrong, and it still doesn't work. Could you please help to edit code directly below original default.aspx file?
Code:
<%@ Page Language="C#" AutoEventWireup="true" ValidateRequest="false" Inherits="YAF.ForumPageBase" %>
<%@ Register TagPrefix="YAF" Assembly="YAF" Namespace="YAF" %>
<script runat="server">
	
</script>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head id="YafHead" runat="server">
    <meta id="YafMetaScriptingLanguage" http-equiv="Content-Script-Type" runat="server"
        name="scriptlanguage" content="text/javascript" />
    <meta id="YafMetaStyles" http-equiv="Content-Style-Type" runat="server" name="styles"
        content="text/css" />
    <meta id="YafMetaDescription" runat="server" name="description" content="Yet Another Forum.NET -- A bulletin board system written in ASP.NET" />
    <meta id="YafMetaKeywords" runat="server" name="keywords" content="Yet Another Forum.net, Forum, ASP.NET, BB, Bulletin Board, opensource" />
    <meta name="HandheldFriendly" content="true"/>
    <meta name="viewport" content="width=device-width,user-scalable=yes"/>
    <title></title>
</head>
<body style="margin: 0; padding: 5px">
    <asp:HyperLink runat="server" id="BannerLink" >
        <img src="~/forumlogo.jpg" runat="server" alt="logo" style="border: 0;" id="imgBanner" />
    </asp:HyperLink>
    <br />
    <form id="form1" runat="server" enctype="multipart/form-data">
    <YAF:Forum runat="server" ID="forum" BoardID="1">
    </YAF:Forum>
    </form>
</body>
</html>


Just double check. Should I add below code on top of theme.css?
Code:
.ctr {
    margin-left: auto;
    margin-right: auto;
}
Thanks
Offline Zero2Cool  
#26 Posted : Saturday, May 16, 2015 9:15:13 AM(UTC)
Zero2Cool


Rank: YAF Leader

Reputation:

Medals: Medal of Honor for the Support Knight: Given to a community member who has assisted lots and lots of people!

Joined: 4/26/2011(UTC)
Posts: 1,062
Man
United States
Location: in a van down by the river

Thanks: 234 times
Was thanked: 101 time(s) in 92 post(s)
Code:
<%@ Page Language="C#" AutoEventWireup="true" ValidateRequest="false" Inherits="YAF.ForumPageBase" %>
<%@ Register TagPrefix="YAF" Assembly="YAF" Namespace="YAF" %>
<script runat="server">
	
</script>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head id="YafHead" runat="server">
    <meta id="YafMetaScriptingLanguage" http-equiv="Content-Script-Type" runat="server"
        name="scriptlanguage" content="text/javascript" />
    <meta id="YafMetaStyles" http-equiv="Content-Style-Type" runat="server" name="styles"
        content="text/css" />
    <meta id="YafMetaDescription" runat="server" name="description" content="Yet Another Forum.NET -- A bulletin board system written in ASP.NET" />
    <meta id="YafMetaKeywords" runat="server" name="keywords" content="Yet Another Forum.net, Forum, ASP.NET, BB, Bulletin Board, opensource" />
    <meta name="HandheldFriendly" content="true"/>
    <meta name="viewport" content="width=device-width,user-scalable=yes"/>
    <title></title>
</head>
<body style="margin: 0; padding: 5px">
    <asp:HyperLink runat="server" id="BannerLink" >
        <img src="~/forumlogo.jpg" runat="server" alt="logo" style="border: 0;" id="imgBanner" />
    </asp:HyperLink>
    <br />
    <form id="form1" runat="server" enctype="multipart/form-data">
<div class="ctr">
    <YAF:Forum runat="server" ID="forum" BoardID="1">
    </YAF:Forum>
</div>
    </form>
</body>
</html>


This is what you should have in the default.aspx page.
Offline trumso  
#27 Posted : Saturday, May 16, 2015 10:16:24 AM(UTC)
trumso


Rank: YAF Camper

Reputation:

Joined: 5/2/2015(UTC)
Posts: 22
United States

Thanks: 10 times
Nothing change Sad
Could you please confirm what I need to do on theme.css? Thanks
Offline Zero2Cool  
#28 Posted : Saturday, May 16, 2015 10:48:29 AM(UTC)
Zero2Cool


Rank: YAF Leader

Reputation:

Medals: Medal of Honor for the Support Knight: Given to a community member who has assisted lots and lots of people!

Joined: 4/26/2011(UTC)
Posts: 1,062
Man
United States
Location: in a van down by the river

Thanks: 234 times
Was thanked: 101 time(s) in 92 post(s)
Originally Posted by: trumso Go to Quoted Post
Nothing change Sad
Could you please confirm what I need to do on theme.css? Thanks


Remove that div ctr class from your default.aspx.

Then in your theme.css

add margin:0 auto; to the yafnet, body element.

/* Change forum's background color */
.yafnet, body {
background-color: #E0FFFF;
margin:0 auto;
}

thanks 1 user thanked Zero2Cool for this useful post.
trumso on 5/16/2015(UTC)
Offline trumso  
#29 Posted : Saturday, May 16, 2015 11:08:39 AM(UTC)
trumso


Rank: YAF Camper

Reputation:

Joined: 5/2/2015(UTC)
Posts: 22
United States

Thanks: 10 times
Found out the answer Smile

Edited by user Saturday, May 16, 2015 12:55:08 PM(UTC)  | Reason: Not specified

Offline trumso  
#30 Posted : Thursday, May 28, 2015 10:43:45 PM(UTC)
trumso


Rank: YAF Camper

Reputation:

Joined: 5/2/2015(UTC)
Posts: 22
United States

Thanks: 10 times
Dear tha_watcha & Zero2Cool,

I really appreciate if you could you please help to write a BB code for below music website? Many thanks.

Code:
<object width="300" height="286">  <param name="movie" value="http://www.nhaccuatui.com/m/WwaehzZ8yV" />  <param name="quality" value="high" />  <param name="wmode" value="transparent" />  <param name="allowscriptaccess" value="always" /> <param name="allowfullscreen" value="true"/> <param name="flashvars" value="autostart=true" />  <embed src="http://www.nhaccuatui.com/m/WwaehzZ8yV" flashvars="target=blank&autostart=true" allowscriptaccess="always" allowfullscreen="true" quality="high" wmode="transparent" type="application/x-shockwave-flash" width="300" height="286"></embed></object>

PS. The number "m/WwaehzZ8yV" is a variable.

Edited by user Thursday, May 28, 2015 10:46:22 PM(UTC)  | Reason: Not specified

Rss Feed  Atom Feed
Users browsing this topic
2 Pages<12
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Notification

Icon
Error