jackiechou
  • Posts: 27
  • Joined: 08/11/2013
Hi YAF Team,
I have my site thegioi360.vn by yafnet forum. And it works okay for a long time, but now it is got stuck with a issue. The install screen appears, and if I click install, the error message is shown below

FILE:
mssql/install/providers/procedures.sql

ERROR:
There is already an object named 'yaf_prov_upgrade' in the database.


CREATE PROCEDURE [dbo].[yaf_prov_upgrade]
(
@PreviousVersion int,
@NewVersion int,
@UTCTIMESTAMP datetime
)

I wonder whether there is a new version and the auto updating proces makes the forum error or not
Please help me ! Give me an advice if possible.

Thanks,
Jackie
Sponsor
tha_watcha
  • Posts: 4079
  • Joined: 06/03/2010
There is is a problem with the upgrade proccess which in some cases run the install script on a upgrade instead of the upgrade script. this will be fixed in the next version.

You can try to skip the upgrade process by increasing the version in the sql table with...

update [{databaseOwner}].[{objectQualifier}registry] set Value = '60' where lower(Name)=lower('version')

UserPostedImage
Users browsing this topic
    Similar Topics
    Forum Jump  
    • You cannot post new topics in this forum.
    • You cannot reply to topics in this forum.
    • You cannot delete your posts in this forum.
    • You cannot edit your posts in this forum.
    • You cannot create polls in this forum.
    • You cannot vote in polls in this forum.

    About Us

    The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

    Powered by Resharper Donate with PayPal button

    Project Twitter Updates

    Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved