tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2020-01-31T09:15:46Z
Can I use an ico file as board logo?
Must I place it only in /images/Logos/ folder or it can be anywhere in the web and I can use URL like https://example.com/favicon.ico? 

If we can't use existing ico files as board logo, I strongly recommend that you add this feature in the next update. I think there are many customers of YAF who needs this feature. Why? Because we already have the 'main' website that already uses a favicon, and we want to share the same icon with the forum. Another reason: it's hard to convert existing bitmap icons to SVG and get the same quality image if you do not have the source in a vector graphics format.
Sponsor
tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2020-01-31T11:29:40Z
I've managed to create an SVG logo for our forum from our main website's favicon. I uploaded this SVG to /Images/Logos/ on the server, chose the SVG in the board setting but still see the same default YAF SVG as the board logo in browser tabs. I tried different browsers, cleared cache, but nothing helps. Am I doing something wrong?
tha_watcha
2020-01-31T14:58:14Z
The board logo and favicon are two different items. the board logo is displayed in the the header. and the favicon is displayed in the browser tab.

The favicon needs to be replaced in the folder Content\favicons
UserPostedImage
tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2020-01-31T15:34:27Z
Is the board logo SVG displayed in the following control in default.aspx?

<asp:HyperLink runat="server" id="BannerLink" CssClass="forum-logo my-4" >
</asp:HyperLink>


I remove it with every forum upgrade because it take too much useful space ;)

As for the favicon in browser tabs, I replaced favicon-16x16.png and favicon-32x32.png in Content\favicons, but this did not help. What should I do more?
tha_watcha
2020-01-31T15:46:11Z
Originally Posted by: tecman 

Is the board logo SVG displayed in the following control in default.aspx?

<asp:HyperLink runat="server" id="BannerLink" CssClass="forum-logo my-4" >
</asp:HyperLink>


I remove it with every forum upgrade because it take too much useful space ;)



Yes that is the logo

Originally Posted by: tecman 


As for the favicon in browser tabs, I replaced favicon-16x16.png and favicon-32x32.png in Content\favicons, but this did not help. What should I do more?



the favicon.ico is the one you need to replace

UserPostedImage
tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2020-01-31T16:04:57Z
But there is no favicon.ico file in that folder!! And adding my favicon.ico to it does not help.
tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2020-01-31T16:06:59Z
BTW, I also tried the good old way of specifying favicon in the <head> section in default.aspx


<head id="YafHead" runat="server">
<link rel="shortcut icon" href="https://example.com/favicon.ico" type="image/x-icon" />
 </head>


And this also does not work in YAF 2.3 (it worked in YAF 2.2).

Please, help!
tha_watcha
2020-01-31T20:24:19Z
Looks like i forgot to include the ico. File i will include it in the next update.

If i look at your site .../forum/Content/favicons/favicon-32x32.png shows still the default icon. Are you sure you replaced all files?
UserPostedImage
tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2020-02-01T05:34:46Z
Yes, I had replaced those 16x16 and 32x32 png files but it did not help. I replaced them again after reading your previous post and it still does not work.

Please, help! It seems, there is a problem with the favicon in YAF 2.30.7 I amusing.
tha_watcha
2020-02-01T19:49:58Z
after you replaced it shows the correct favicon in chrome, on your site. Did you clear your browser cache?
UserPostedImage
tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2020-02-03T09:26:00Z
Strange. I swear I remember to clear the browser cache before testing such things, and I guessed I had done it. I "forget" my website in my Firefox, and now the correct favicon appears in the browser tab.

So, do we need to replace/add only the favicon.icon file to the /Content/favicons/ directory to make the favicon work? Where favicon-16x16.png and favicon-32x32.png are used? Do we need to replace those png files too to make the favicon work?
tha_watcha
2020-02-03T12:24:36Z
the ico is a fallback icon for old ie. All current browsers using the bigger png files.
UserPostedImage
tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2020-02-03T13:08:32Z
As I can see from the HTML produced by the YAF engine

<link href="/forum/Content/favicons/apple-touch-icon.png" rel="apple-touch-icon" sizes="180x180" />
<link href="/forum/Content/favicons/favicon-32x32.png" rel="icon" sizes="32x32" />
<link href="/forum/Content/favicons/favicon-16x16.png" rel="icon" sizes="16x16" />
<link href="/forum/Content/favicons/site.webmanifest" rel="manifest" />
<link href="/forum/Content/favicons/safari-pinned-tab.svg" rel="mask-icon" color="#5bbad5" />
<link href="/forum/Content/favicons/favicon.ico" rel="shortcut icon" />
<meta name="msapplication-TileColor" content="#da532c" />
<meta name="msapplication-config" content="/forum/Content/favicons/browserconfig.xml" />


, we also need to prepare android-chrome-144x144.png, apple-touch-icon.png, mstile-150x150.png, safari-pinned-tab.svg. Doing this may be tedious, especially for SVG for the reasons I described above. What if we simply remove them from /Content/favicons/? Will our 16x16, 32x32 PNGs and favicon.ico will be used on Apple and Android as 'fallback' favicons?

It would be nice to have the ability no to specify all those specialized icons at all. Maybe, with a setting in the forum.

BTW. I do not see that android-chrome-144x144.png is used anywhere. Do we really need it?
tha_watcha
2020-02-03T14:12:13Z
Quote:

Doing this may be tedious, especially for SVG for the reasons I described above.



Why? Thats why online generators exist. Just upload your logo and it creates all files for you.

https://favicon.io/favicon-converter/ 
UserPostedImage
tecman
  •  tecman
  • 100% (Exalted)
  • YAF All-the-Time Topic Starter
2020-02-03T14:42:12Z
Online converters are good if you have a source icon (bitmap) of a big size that can be downscaled to PNG bitmaps of smaller sizes with good quality. But what if you have a favicon icon of 16x16 or max 32x32? Upscaling it to 144x144 and bigger sizes will produce very blurry images...

I asked about android-chrome-144x144.png. Do we really need it?

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved