stardv
  • Posts: 5
  • Joined: 29/07/2008

I am trying to integrate YAF with exiting web site that is using standard asp.net membership providers with standard asp_net membership tables "aspnet_Users" and "aspnet_Membership". I have tried all things recommended in the forum by adding membership tag into web.config and creating standard provider but it does not seem to work.

Please let me know what I am doing wrong. I must be missing something.

As I see by default YAF is using "yaf_User" table as a provider for the membership and user storage. Adding membership into web.config does not change that behavior. It must be something more that I am missing that was not specified in any of the forum messages so I can point YAF to existing member tables I am using for my application "aspnet_Users" and "aspnet_Membership"

This what I added to web.config

<membership>
<providers>
<remove name="AspNetSqlMembershipProvider"/>
<add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" connectionStringName="ConnString" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" applicationName="ProjectUp" requiresUniqueEmail="false" passwordFormat="Hashed" maxInvalidPasswordAttempts="10" minRequiredPasswordLength="7" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" passwordStrengthRegularExpression=""/>
</providers>
</membership>


Please help
Sponsor
stardv
  • Posts: 5
  • Joined: 29/07/2008
Anybody please :roll: :roll: :roll:
Mek
  • Posts: 892
  • Joined: 12/07/2005
You are using 1.93 right? As this is the only version compatible with the providers. In which case it doesn't use yaf_user as the provider table, but rather syncs a new table with that table (the give away is the UserProviderKey field).


UserPostedImage 

"It's a case of RTFM.. the only problem being we don't have a manual!"

When I post FP:Mek in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting. (Yes I stole this off Ederon 🙂 )
stardv
  • Posts: 5
  • Joined: 29/07/2008
Daa, my bad, I spent few days reading messages on how to use stand art membership and banged my head against the wall why I could not make it work.
I though it might have to do with the YAF version but I had no doubt since I downloaded the latest one available. However, after many hours I realized that I need 19.3 that is BETA and thanks to forums post I did download it

THNKS TAHNKS TAHNKS
Users browsing this topic
    Forum Jump  
    • You cannot post new topics in this forum.
    • You cannot reply to topics in this forum.
    • You cannot delete your posts in this forum.
    • You cannot edit your posts in this forum.
    • You cannot create polls in this forum.
    • You cannot vote in polls in this forum.

    About Us

    The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

    Powered by Resharper Donate with PayPal button

    Project Twitter Updates

    Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved