Jaben
  • Posts: 2544
  • Joined: 09/10/2004
mack wrote:

mack wrote:

I found a possible bug. When you 'report spam' or 'report abuse'.. can click 'moderate'. You can click the number of reports to I guess view data, but I get the error:
System.ArgumentException: Flags is neither a DataColumn nor a DataRelation for table Table.
at System.Data.DataRowView.get_Item(String property)
at YAF.Pages.moderate.reportedposts.FormatMessage(DataRowView row)
at ASP.pages_moderate_reportedposts_ascx.__DataBind__control15(Object sender, EventArgs e)
at System.Web.UI.Control.OnDataBinding(EventArgs e)
at System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding)
at System.Web.UI.Control.DataBindChildren()
at System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding)
at System.Web.UI.WebControls.Repeater.CreateControlHierarchy(Boolean useDataSource)
at System.Web.UI.WebControls.Repeater.OnDataBinding(EventArgs e)
at System.Web.UI.Control.DataBindChildren()
at System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding)
at YAF.Pages.moderate.reportedposts.BindData()
at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)
at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)
at System.EventHandler.Invoke(Object sender, EventArgs e)
at System.Web.UI.Control.OnLoad(EventArgs e)
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)



I can also report myself... I am using the SVN version. Not sure if this version will do it.



You need to re-run the install and update the SQL from the latest version.

mack
  • Posts: 90
  • Joined: 25/11/2005
Thanks! I updated the latest SVN and it worked! Sweet.
mack
  • Posts: 90
  • Joined: 25/11/2005
I'm back with more. I have the latest SVN and I get this error when trying to delete a forum:


System.Data.SqlClient.SqlException: The DELETE statement conflicted with the REFERENCE constraint "FK_yaf_Topic_yaf_Poll". The conflict occurred in database "BlackCrystalDb", table "dbo.yaf_Topic", column 'PollID'.
The statement has been terminated.
   at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection)
   at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
   at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)
   at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString)
   at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async)
   at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, DbAsyncResult result)
   at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(DbAsyncResult result, String methodName, Boolean sendToPipe)
   at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
   at YAF.Classes.Data.DBAccess.ExecuteNonQuery(SqlCommand cmd, Boolean transaction) in S:\Websites\yafdotnet\trunk\yafsrc\YAF.Classes\YAF.Classes.Data\DBAccess.cs:line 390
   at YAF.Classes.Data.DB.topic_delete(Object topicID, Object eraseTopic) in S:\Websites\yafdotnet\trunk\yafsrc\YAF.Classes\YAF.Classes.Data\DB.cs:line 2970
   at YAF.Classes.Data.DB.forum_deleteAttachments(Object forumID) in S:\Websites\yafdotnet\trunk\yafsrc\YAF.Classes\YAF.Classes.Data\DB.cs:line 1046
   at YAF.Classes.Data.DB.forum_delete(Object forumID) in S:\Websites\yafdotnet\trunk\yafsrc\YAF.Classes\YAF.Classes.Data\DB.cs:line 1067
   at YAF.Pages.Admin.forums.ForumList_ItemCommand(Object source, RepeaterCommandEventArgs e)
   at System.Web.UI.WebControls.Repeater.OnBubbleEvent(Object sender, EventArgs e)
   at System.Web.UI.Control.RaiseBubbleEvent(Object source, EventArgs args)
   at System.Web.UI.WebControls.RepeaterItem.OnBubbleEvent(Object source, EventArgs e)
   at System.Web.UI.Control.RaiseBubbleEvent(Object source, EventArgs args)
   at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument)
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)


Thanks again :-d
mack
  • Posts: 90
  • Joined: 25/11/2005
I was able to delete the forum after I deleted the poll inside of it. Which gave me the idea after reading the error message. I'm also curious.. I noticed that the path:
"S:\Websites\yafdotnet\trunk\yafsrc\YAF.Classes\YAF.Classes.Data\DBAccess.cs".. thats my computer. I'm not running it on my computer, I'm running it on a dedicated server. Why the heck is it saying the error is there? I checked the date/time, it's 5:21 AM 2/6/09 which is when that error occurred.. weird!
mack
  • Posts: 90
  • Joined: 25/11/2005
I don't know why we can't edit our posts here :(

Anyway, I found another bug (YAY). When I create a subforum, and then go to it and try to create a new topic it sends me back to the wrong discussion forum. Not sure why; if it's a cache problem or what. I did clear the cache. Next time it happens I will reset the application pool it runs on. Right now it's on a shared application pool for basic websites. That could be the issue, not sure. Anyone else have this error? It seems to fix itself after a few minutes. That's why I think it's cache related.
midwestSS
  • Posts: 357
  • Joined: 17/08/2008
mack wrote:

I don't know why we can't edit our posts here :(

Anyway, I found another bug (YAY). When I create a subforum, and then go to it and try to create a new topic it sends me back to the wrong discussion forum. Not sure why; if it's a cache problem or what. I did clear the cache. Next time it happens I will reset the application pool it runs on. Right now it's on a shared application pool for basic websites. That could be the issue, not sure. Anyone else have this error? It seems to fix itself after a few minutes. That's why I think it's cache related.




Have you turned "is moderated" off?
Jaben
  • Posts: 2544
  • Joined: 09/10/2004
mack wrote:

I don't know why we can't edit our posts here :(



Just an oversight... should work now.
mack
  • Posts: 90
  • Joined: 25/11/2005
Jaben wrote:

mack wrote:

I don't know why we can't edit our posts here :(



Just an oversight... should work now.



Thanks, I don't want to spam the forums with bug reports etc. Keep up the good work :-d
schworak
  • Posts: 9
  • Joined: 10/02/2009
The upgrade looks awesome. I am running 1.9.1 under DNN right now. Any idea when the new version will be available for DNN? Or even when the official release will be out? The BBCodes are my #1 concern the the moment but the over look/feel of the new version is fantastic.
mack
  • Posts: 90
  • Joined: 25/11/2005
I fixed this issue, I reran the installer. I updated to the latest SVN, and I can't login. It says wrong user name and password. What changed that would cause this? Messed with it for a few hours and it's not working. Redownloaded, recompiled, etc. Cleaned web.config, updated DB, and so on. Now I'm to the point that I can't see things that pop up to say the password is wrong. It doesn't do anything now when I login.

On my current forum (live), when someone tried to login they get an error saying the password was wrong.

This is what they said:

Quote:

I just wanted to aswer the questions on the forum and I see that I
> cannot log in to it. Everytime I type in username and the right
> password and press Log In, I'm redirected to the forum as if I weren't
> logged in. I tried to delete cookies and to use a different
> browser(IE) but that didn't work either. Is that a problem you know or
> is that something new?



And then:
Quote:


I figured out that when I try to login from another IP address, it throws
> an
> error "Your login attempt was not successful. Please try again". I think
> the
> best solution would be if you deleted my account and I would then create
> a
> new one.

test2005
  • Posts: 761
  • Joined: 12/02/2005

FTS is not enabled. Run the FTS script.


.....the man in black fled across the desert..........and the gunslinger followed.....
mack
  • Posts: 90
  • Joined: 25/11/2005
Fixed read ^^
mack
  • Posts: 90
  • Joined: 25/11/2005
Here are the errors I get when the user creates/login:

Quote:


System.Threading.ThreadAbortException: Thread was being aborted.
at System.Configuration.BaseConfigurationRecord.Init(IInternalConfigRoot configRoot, BaseConfigurationRecord parent, String configPath, String locationSubPath)
at System.Configuration.Internal.InternalConfigRoot.GetConfigRecord(String configPath)
at System.Configuration.Internal.InternalConfigRoot.GetUniqueConfigRecord(String configPath)
at System.Web.CachedPathData.Init(CachedPathData parentData)
at System.Web.CachedPathData.GetConfigPathData(String configPath)
at System.Web.CachedPathData.GetConfigPathData(String configPath)
at System.Web.CachedPathData.GetConfigPathData(String configPath)
at System.Web.Configuration.HttpConfigurationSystem.System.Configuration.Internal.IInternalConfigSystem.GetSection(String configKey)
at System.Configuration.ConfigurationManager.GetSection(String sectionName)
at System.Configuration.ConfigurationManager.get_ConnectionStrings()
at YAF.Classes.Config.get_ConnectionString() in S:\Websites\yafdotnet\trunk\yafsrc\YAF.Classes\YAF.Classes.Config\Config.cs:line 205
at YAF.Classes.Data.YafDBConnManager.InitConnection() in S:\Websites\yafdotnet\trunk\yafsrc\YAF.Classes\YAF.Classes.Data\DBAccess.cs:line 50
at YAF.Classes.Data.DBAccess.GetDatasetBasic(SqlCommand cmd, Boolean transaction) in S:\Websites\yafdotnet\trunk\yafsrc\YAF.Classes\YAF.Classes.Data\DBAccess.cs:line 263
at YAF.Classes.Data.DBAccess.GetData(SqlCommand cmd, Boolean transaction) in S:\Websites\yafdotnet\trunk\yafsrc\YAF.Classes\YAF.Classes.Data\DBAccess.cs:line 327
at YAF.Classes.Data.DB.mail_list(Object processId) in S:\Websites\yafdotnet\trunk\yafsrc\YAF.Classes\YAF.Classes.Data\DB.cs:line 1541
at YAF.Classes.Utils.SendMailThread.SendMailThreaded(Int32 uniqueId) in S:\Websites\yafdotnet\trunk\yafsrc\YAF.Classes\YAF.Classes.Utils\Mail\SendMail.cs:line 114



Quote:


System.Web.HttpException: Validation of viewstate MAC failed. If this application is hosted by a Web Farm or cluster, ensure that configuration specifies the same validationKey and validation algorithm. AutoGenerate cannot be used in a cluster. ---> System.Web.UI.ViewStateException: Invalid viewstate.
Client IP: IP
Port: 2350
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)
ViewState: /wEPDwUKLTY5MjQzNzA1NQ9kFgICBQ9kFgICAQ9kFgICAg9kFgZmD2QWAmYPZBYCAgEPZBYEZg9kFgJmDw8WAh4EVGV4dAUMTm90aWZpY2F0aW9uZGQCAg9kFgRmDw8WBB8ABQJPSx4NT25DbGllbnRDbGljawUyJGZpbmQoJ0ZvcnVtUGFnZUVycm9yUG9wdXAnKS5oaWRlKCk7IHJldHVybiBmYWxzZTtkZAIBDw8WAh8ABQZDYW5jZWwWAh4Fc3R5bGUFDGRpc3BsYXk6bm9uZWQCAQ8WAh4KUGFnZUxpbmtEVDLoCwABAAAA/////wEAAAAAAAAADAIAAABOU3lzdGVtLkRhdGEsIFZlcnNpb249Mi4wLjAuMCwgQ3VsdHVyZT1uZXV0cmFsLCBQdWJsaWNLZXlUb2tlbj1iNzdhNWM1NjE5
Referer: http://forums.black-crys...schedule-for-SUNDAY.aspx 
Path: /Default.aspx ---> System.Web.HttpException: Unable to validate data.
at System.Web.Configuration.MachineKeySection.GetDecodedData(Byte[] buf, Byte[] modifier, Int32 start, Int32 length, Int32& dataLength)
at System.Web.UI.ObjectStateFormatter.Deserialize(String inputString)
--- End of inner exception stack trace ---
--- End of inner exception stack trace ---
at System.Web.UI.ViewStateException.ThrowError(Exception inner, String persistedState, String errorPageMessage, Boolean macValidationError)
at System.Web.UI.ObjectStateFormatter.Deserialize(String inputString)
at System.Web.UI.Util.DeserializeWithAssert(IStateFormatter formatter, String serializedState)
at System.Web.UI.HiddenFieldPageStatePersister.Load()
at System.Web.UI.Page.LoadPageStateFromPersistenceMedium()
at System.Web.UI.Page.LoadAllState()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Error Guest 3/7/2009 6:04:15 AM



Quote:


System.FormatException: Input string was not in a correct format.
at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
at System.Number.ParseDecimal(String value, NumberStyles options, NumberFormatInfo numfmt)
at YAF.Classes.Utils.YafStaticData.TimeZones() in S:\Websites\yafdotnet\trunk\yafsrc\YAF.Classes\YAF.Classes.Utils\StaticData.cs:line 46
at YAF.Pages.register.Page_Load(Object sender, EventArgs e)
at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)
at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)
at System.EventHandler.Invoke(Object sender, EventArgs e)
at System.Web.UI.Control.OnLoad(EventArgs e)
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)



sainath
  • Posts: 1
  • Joined: 10/03/2009
:oops: :oops: :oops: :| :| :| :| :| :| :| :| :twisted: :shock: :roll: 😎 :-d :arrow: :!: :arrowd: :evil: :idea: :lol: 😮
okeyes wrote:

Jaben wrote:

ivanpank wrote:

Jaben wrote:

ivanpank wrote:

Is there anything wrong here?

line 529, file ReplaceRules.cs

private string _replaceFormat = "黢襸1}曛{0}蹑?;


If it works, than it's fine.



It can't work.


Please explain. This is the actual code: "÷ñÒ{1}êÖ{0}õæ÷"




there is wrong yet..some thing need to be fix.


mack
  • Posts: 90
  • Joined: 25/11/2005
Fixed my issue by having both the people switch their default language to US/English.
Users browsing this topic
    Forum Jump  
    • You cannot post new topics in this forum.
    • You cannot reply to topics in this forum.
    • You cannot delete your posts in this forum.
    • You cannot edit your posts in this forum.
    • You cannot create polls in this forum.
    • You cannot vote in polls in this forum.

    About Us

    The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

    Powered by Resharper Donate with PayPal button

    Project Twitter Updates

    Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved