chrisgr
  • Posts: 29
  • Joined: 24/01/2009
Yep, I'm back! Been working on customizing YAF to my new, unpublished site. I'm getting errors during any build. I'm using Visual Web Developer 2008, 1.9.3 SRC files. When I open the source file, I have to convert as it is an older file. Conversion goes well. However even after a virgin conversion I do a rebuild (or a build with and w/o cleaning prior) I get 106 errors all indicating Unknown Server Tag. I'm not editing the src file at all at this point. Is this something I should be concerned about? Intellisense does show a lot of transitional errors as well as unrecognized tag prefixes or device filter throught the pages.

I've tried compiling in 2.0 as well as 3.0 and 3.5 framework. I'm running asp.net 3.5.
Many thanks!!
Chris
Here are a couple lines of errors.
D:\193srcunzipped\YetAnotherForum.NET\controls\ForumLastPost.ascx(12): Build (web): Unknown server tag 'YAF:UserLink'.
D:\193srcunzipped\YetAnotherForum.NET\controls\ForumLastPost.ascx(12): Build (web): Unknown server tag 'YAF:ThemeImage'.
D:\193srcunzipped\YetAnotherForum.NET\controls\ForumLastPost.ascx(15): Build (web): Unknown server tag 'YAF:LocalizedLabel'.
D:\193srcunzipped\YetAnotherForum.NET\controls\ForumStatistics.ascx(3): Build (web): Unknown server tag 'asp:UpdatePanel'.
Sponsor
book_man25
  • Posts: 21
  • Joined: 05/06/2007
You'll need to move one of the web.config files from the webconfigs directory up one directory before you compile. Just make sure you rename it to web.config and it's in the same folder as the app.config and bin folder when you're trying to compile.
chrisgr
  • Posts: 29
  • Joined: 24/01/2009
Thank you for the quick response!! I had a brain freeze last night. I did do this before but I scrapped my project and started over with a virgin src zip and obviously, forgot the basics.
Again, thanks!!
biggerbyfar
  • Posts: 5
  • Joined: 30/07/2009
I have this issue too, but I do have web.config in place. I copied the "recommended-NETv3.5-web.config" into the website root.

the 9 other projects compile fine (8x Yaf.x and Intelligencia.UrlRewriter projects) but the website project gives me about 100 errors all saying something like:

Error 8 Unknown server tag 'YAF:UserLink'. D:\Projects\YetAnotherForum\YetAnotherForum.NET\controls\ForumModeratorList.ascx
Error 9 Unknown server tag 'YAF:LocalizedLabel'. D:\Projects\YetAnotherForum\YetAnotherForum.NET\controls\ForumLastPost.ascx
Error 10 Unknown server tag 'YAF:LocalizedLabel'. D:\Projects\YetAnotherForum\YetAnotherForum.NET\controls\ForumLastPost.ascx

etc.

I don't normally work with website projects, only web application projects so that may be tripping me up. I am working with the latest YAF-v1.9.3-FINAL-SRC.zip package.

Any ideas? I'm using .net 3.5
biggerbyfar
  • Posts: 5
  • Joined: 30/07/2009
biggerbyfar wrote:

I have this issue too, but I do have web.config in place. I copied the "recommended-NETv3.5-web.config" into the website root.

the 9 other projects compile fine (8x Yaf.x and Intelligencia.UrlRewriter projects) but the website project gives me about 100 errors all saying something like:

Error 8 Unknown server tag 'YAF:UserLink'. D:\Projects\YetAnotherForum\YetAnotherForum.NET\controls\ForumModeratorList.ascx
Error 9 Unknown server tag 'YAF:LocalizedLabel'. D:\Projects\YetAnotherForum\YetAnotherForum.NET\controls\ForumLastPost.ascx
Error 10 Unknown server tag 'YAF:LocalizedLabel'. D:\Projects\YetAnotherForum\YetAnotherForum.NET\controls\ForumLastPost.ascx

etc.

I don't normally work with website projects, only web application projects so that may be tripping me up. I am working with the latest YAF-v1.9.3-FINAL-SRC.zip package.

Any ideas? I'm using .net 3.5



Urg, scrap that. I have a weird corrupt web.config somehow. I copied a fresh web.config into the root and now those errors are gone.
biggerbyfar
  • Posts: 5
  • Joined: 30/07/2009
Now I just get these four errors. Again I expect this is to do with website projects 😞 Any ideas anyone? :

Error 3 The type 'System.Web.UI.ScriptManager' exists in both 'c:\Windows\assembly\GAC_MSIL\System.Web.Extensions\3.5.0.0__31bf3856ad364e35\System.Web.Extensions.dll' and 'c:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\yetanotherforum.net\152155b3\12fa5cef\assembly\dl3\9be85634\007e8b65_5ac0c901\System.Web.Extensions.DLL' D:\Projects\YetAnotherForum\YetAnotherForum.NET\App_Code\YAF\Forum.cs 87 10 D:\...\YetAnotherForum.NET\

Error 4 The type 'System.Web.UI.ScriptManager' exists in both 'c:\Windows\assembly\GAC_MSIL\System.Web.Extensions\3.5.0.0__31bf3856ad364e35\System.Web.Extensions.dll' and 'c:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\yetanotherforum.net\152155b3\12fa5cef\assembly\dl3\9be85634\007e8b65_5ac0c901\System.Web.Extensions.DLL' D:\Projects\YetAnotherForum\YetAnotherForum.NET\App_Code\YAF\Forum.cs 90 6 D:\...\YetAnotherForum.NET\

Error 5 The type 'System.Web.UI.ScriptManager' exists in both 'c:\Windows\assembly\GAC_MSIL\System.Web.Extensions\3.5.0.0__31bf3856ad364e35\System.Web.Extensions.dll' and 'c:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\yetanotherforum.net\152155b3\12fa5cef\assembly\dl3\9be85634\007e8b65_5ac0c901\System.Web.Extensions.DLL' D:\Projects\YetAnotherForum\YetAnotherForum.NET\App_Code\YAF\Forum.cs 90 43 D:\...\YetAnotherForum.NET\

Error 6 The type 'System.Web.UI.ScriptManager' exists in both 'c:\Windows\assembly\GAC_MSIL\System.Web.Extensions\3.5.0.0__31bf3856ad364e35\System.Web.Extensions.dll' and 'c:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\yetanotherforum.net\152155b3\12fa5cef\assembly\dl3\9be85634\007e8b65_5ac0c901\System.Web.Extensions.DLL' D:\Projects\YetAnotherForum\YetAnotherForum.NET\App_Code\YAF\ForumEditor.cs 318 4 D:\...\YetAnotherForum.NET\

biggerbyfar
  • Posts: 5
  • Joined: 30/07/2009
Ok this is pretty tricky to sort out, but I'm posting it here to help others.

The ScriptManager issue is something to do with the class moving from one area to another between going from a microsoft beta release and the final non-beta location. Old references seem to cause the issue.

To resolve this, in VS2008 go to the website project 'YetAnotherForum.net' go to [property pages] > [Build] > [Target Framework]. By defult when using the "recommended-NETv3.5-web.config" this will be set to ".NET Framework 3.5". Change this to ".NET Framework 2.0". Select 'OK'. Then go back to the same page and set it back to ".NET Framework 3.5". Select OK.

Check your web.config and you'll see it has added this section to the bottom:

<runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
<assemblyIdentity name="System.Web.Extensions" publicKeyToken="31bf3856ad364e35"/>
<bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/></dependentAssembly>
<dependentAssembly>
<assemblyIdentity name="System.Web.Extensions.Design" publicKeyToken="31bf3856ad364e35"/>
<bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/></dependentAssembly></assemblyBinding></runtime></configuration>


Recompile the solution and the assembly / GAC errors have gone.

I did also have one remaining compilation error:

Error 3 Could not load file or assembly 'nStuff.UpdateControls' or one of its dependencies. The system cannot find the file specified. D:\Projects\YetAnotherForum\YetAnotherForum.NET\pages\search.ascx

To fix this, I copied the nStuff.UpdateControls.dll from /Bin/Net3.5/nStuff.UpdateControls.dll into the /Bin folder.

After this, I finally got a successful .net 3.5 compilation without any errors.

Phew!

Forum Jump  
  • You cannot post new topics in this forum.
  • You cannot reply to topics in this forum.
  • You cannot delete your posts in this forum.
  • You cannot edit your posts in this forum.
  • You cannot create polls in this forum.
  • You cannot vote in polls in this forum.

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved