Welcome Guest! To enable all features please Login or Register.
6 Pages«<23456>
Options
View
Go to last post Go to first unread
Offline Jaben  
#46 Posted : Friday, October 30, 2009 4:20:48 PM(UTC)
Jaben


Rank: YAF Developer

Reputation:

Medals: Medal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.YAF.NET Supporter: Loves YAF.NET!YAF.NET Supporter: Supports our efforts. Thank you.Medal of Honor for the Support King: Given to a community member who tirelessly answers tons of support questions.

Joined: 10/9/2004(UTC)
Posts: 2,549
Location: United States

Thanks: 142 times
Was thanked: 358 time(s) in 199 post(s)
surieux wrote:
Hello,

I would appreciate to understand the status of this Beta, is it near RTM ? How long for a stable enough version ?
What are the :
1) deprecated
2) less stable
3) not working area
It's evident that many changes have occurred, is it worth working on 1.9.3 when we need adaptations ?

Thanks for some answer.

CS

I believe it's more stable across the board. Not sure what you mean by sections that are depreciated. There is nothing that is non-functional.
Offline Jaben  
#47 Posted : Friday, October 30, 2009 4:21:51 PM(UTC)
Jaben


Rank: YAF Developer

Reputation:

Medals: Medal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.YAF.NET Supporter: Loves YAF.NET!YAF.NET Supporter: Supports our efforts. Thank you.Medal of Honor for the Support King: Given to a community member who tirelessly answers tons of support questions.

Joined: 10/9/2004(UTC)
Posts: 2,549
Location: United States

Thanks: 142 times
Was thanked: 358 time(s) in 199 post(s)
Updated with 100% COMPLETE DNN Module for v1.9.4 beta 3!

Thanks to DNN's nice new web.config modification section, it now automatically handles YAF web.config modifications automatically.

Please try!
Offline Boskone  
#48 Posted : Saturday, October 31, 2009 4:14:16 AM(UTC)
Boskone


Rank: YAF MVP

Reputation:

Medals: Medal of Honor: Portal Puzzle Master: Given to YAF community members who help unravel the Portal Puzzle and YAF.

Joined: 3/26/2004(UTC)
Posts: 183
Canada

Thanks: 17 times
Was thanked: 4 time(s) in 4 post(s)
I never tested this on a new DNN install yet but I did notice a couple of things in the yaf_dnn.dnn file.

app.config section:
The YAF.FileRoot and YAF.AppRoot keys are not defined.

In the releasenotes.html:
DNN does not install the AspNetRole provider or the AspNetProfle provider. Both of these sections have to be added manually.
So instead of only just modifying the profile provider to inherit YAF.Classes.Utils.YafUserProfile, the entire sections have to be added.

Other than those 2 things everything looks good. Thanks Jaben!

EDIT:
A couple more things that need to be added:
Code:
<section name="rewriter" type="Intelligencia.UrlRewriter.Configuration.RewriterConfigurationSectionHandler, Intelligencia.UrlRewriter" requirePermission="false" />

<rewriter configSource="URLRewriter.config" />

<system.net>
    <mailSettings>
      <smtp configSource="mail.config" />
    </mailSettings>
  </system.net>

Edited by user Saturday, October 31, 2009 5:09:25 AM(UTC)  | Reason: Not specified

Boskone - A DotNetNuke user.
RDSCC
Offline Jaben  
#49 Posted : Saturday, October 31, 2009 6:31:52 AM(UTC)
Jaben


Rank: YAF Developer

Reputation:

Medals: Medal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.YAF.NET Supporter: Loves YAF.NET!YAF.NET Supporter: Supports our efforts. Thank you.Medal of Honor for the Support King: Given to a community member who tirelessly answers tons of support questions.

Joined: 10/9/2004(UTC)
Posts: 2,549
Location: United States

Thanks: 142 times
Was thanked: 358 time(s) in 199 post(s)
Dan... have you gotten UtlRewriter to work with DNN? I didn't think it necessary to add.

Don't see a reason to define File Root or AppRoot as they are set automatically by YAF.

Not sure what to do with the providers... any suggestions?
Offline Boskone  
#50 Posted : Saturday, October 31, 2009 7:01:42 AM(UTC)
Boskone


Rank: YAF MVP

Reputation:

Medals: Medal of Honor: Portal Puzzle Master: Given to YAF community members who help unravel the Portal Puzzle and YAF.

Joined: 3/26/2004(UTC)
Posts: 183
Canada

Thanks: 17 times
Was thanked: 4 time(s) in 4 post(s)
Jaben wrote:
Dan... have you gotten UtlRewriter to work with DNN? I didn't think it necessary to add.

Don't see a reason to define File Root or AppRoot as they are set automatically by YAF.

Not sure what to do with the providers... any suggestions?

I have never tried to get the rewriter to work, I just thought it had to be defined anyway.
Cool, Approot and Fileroot set automatically. Does the install routine do this?

As for the providers, Unless the section can be added, it is still a manual processs, and it would have to be done before installing the db.
Would it be possible to add the providers section in the install routine before the db gets installed?
Boskone - A DotNetNuke user.
RDSCC
Offline Jaben  
#51 Posted : Saturday, October 31, 2009 7:14:19 AM(UTC)
Jaben


Rank: YAF Developer

Reputation:

Medals: Medal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.YAF.NET Supporter: Loves YAF.NET!YAF.NET Supporter: Supports our efforts. Thank you.Medal of Honor for the Support King: Given to a community member who tirelessly answers tons of support questions.

Joined: 10/9/2004(UTC)
Posts: 2,549
Location: United States

Thanks: 142 times
Was thanked: 358 time(s) in 199 post(s)
Boskone wrote:
Jaben wrote:
Dan... have you gotten UtlRewriter to work with DNN? I didn't think it necessary to add.

Don't see a reason to define File Root or AppRoot as they are set automatically by YAF.

Not sure what to do with the providers... any suggestions?

I have never tried to get the rewriter to work, I just thought it had to be defined anyway.
Cool, Approot and Fileroot set automatically. Does the install routine do this?

As for the providers, Unless the section can be added, it is still a manual processs, and it would have to be done before installing the db.
Would it be possible to add the providers section in the install routine before the db gets installed?

The Approot and Fileroot default to the proper values for DNN. They can be overridden, of course. But no reason if using default settings.

providers can be added in the install routines, yes. But it's touchy, I don't want to overwrite anything.
Offline Boskone  
#52 Posted : Saturday, October 31, 2009 10:12:31 AM(UTC)
Boskone


Rank: YAF MVP

Reputation:

Medals: Medal of Honor: Portal Puzzle Master: Given to YAF community members who help unravel the Portal Puzzle and YAF.

Joined: 3/26/2004(UTC)
Posts: 183
Canada

Thanks: 17 times
Was thanked: 4 time(s) in 4 post(s)
I found a way to add the providers in the dnn manifest file.
I am getting some stupid errors about not being able to write to the appsettings section to save the config password (now you know why I bang my head Rolling Eyes )
I'm working on it though.
Boskone - A DotNetNuke user.
RDSCC
Offline Jaben  
#53 Posted : Sunday, November 1, 2009 7:00:39 AM(UTC)
Jaben


Rank: YAF Developer

Reputation:

Medals: Medal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.YAF.NET Supporter: Loves YAF.NET!YAF.NET Supporter: Supports our efforts. Thank you.Medal of Honor for the Support King: Given to a community member who tirelessly answers tons of support questions.

Joined: 10/9/2004(UTC)
Posts: 2,549
Location: United States

Thanks: 142 times
Was thanked: 358 time(s) in 199 post(s)
Boskone wrote:
I found a way to add the providers in the dnn manifest file.
I am getting some stupid errors about not being able to write to the appsettings section to save the config password (now you know why I bang my head Rolling Eyes )
I'm working on it though.

Be nice if the DNN install routine had a place to ask for a value... then I could just write the configPassword at that point.
Offline Boskone  
#54 Posted : Sunday, November 1, 2009 7:03:46 AM(UTC)
Boskone


Rank: YAF MVP

Reputation:

Medals: Medal of Honor: Portal Puzzle Master: Given to YAF community members who help unravel the Portal Puzzle and YAF.

Joined: 3/26/2004(UTC)
Posts: 183
Canada

Thanks: 17 times
Was thanked: 4 time(s) in 4 post(s)
It turned out I had trust set to full instead of high.
Boskone - A DotNetNuke user.
RDSCC
Offline TheNerd  
#55 Posted : Wednesday, November 4, 2009 1:58:23 AM(UTC)
TheNerd


Rank: YAF Camper

Reputation:

Joined: 7/18/2009(UTC)
Posts: 28

Thanks: 1 times
I've gone and installed this beta on a clean install of dnn 5 (latest version) and went in to make a post. The odd thing is, the MOMENTI make the post, the wpw3 worker process on the server completely crashes and all of IIS needs to be reset in order for the system to recover. It happens on a post, an edit, a reply - anything that involves the message. I'm completely at a loss as to how to trouble shoot this - seems like its isolated to me, although I don't know why. this is a dedicated server with a clean install of YAF beta 3 and DNN 5. Jaben, can you point me in any direction as to what to look for? What happens during a post?
Offline TheNerd  
#56 Posted : Wednesday, November 4, 2009 4:36:47 AM(UTC)
TheNerd


Rank: YAF Camper

Reputation:

Joined: 7/18/2009(UTC)
Posts: 28

Thanks: 1 times
TheNerd wrote:
I've gone and installed this beta on a clean install of dnn 5 (latest version) and went in to make a post. The odd thing is, the MOMENTI make the post, the wpw3 worker process on the server completely crashes and all of IIS needs to be reset in order for the system to recover. It happens on a post, an edit, a reply - anything that involves the message. I'm completely at a loss as to how to trouble shoot this - seems like its isolated to me, although I don't know why. this is a dedicated server with a clean install of YAF beta 3 and DNN 5. Jaben, can you point me in any direction as to what to look for? What happens during a post?


So I've narrowed it down to the CreateMail.WatchEmail(nMessageID); line in postmessage.ascx.cs

The interesting thing is I have the webconfig file set up to look at the mail.config. Mail.config is set up properly with the same settings that DNN is configured with, and DNN has no problems sending to this email server. Is there another configuration I am missing somewhere?????
Offline DJGray  
#57 Posted : Wednesday, November 4, 2009 7:30:04 AM(UTC)
DJGray


Rank: YAF Commander

Reputation:

Medals: Medal of Honor for the Support Knight: Given to a community member who has answered lots of support questions.

Joined: 11/19/2007(UTC)
Posts: 96

Was thanked: 4 time(s) in 4 post(s)
logan wrote:
Works Great on GoDaddy, As for the upgrade from 1.9.1.8 to the new beta have not tried it yet.


Having serious difficulty with the Membership section of the web.config. No one can log in. Have tried multiple permutations of the readme instructions and still getting no joy.


Offline Jaben  
#58 Posted : Wednesday, November 4, 2009 9:24:17 AM(UTC)
Jaben


Rank: YAF Developer

Reputation:

Medals: Medal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.YAF.NET Supporter: Loves YAF.NET!YAF.NET Supporter: Supports our efforts. Thank you.Medal of Honor for the Support King: Given to a community member who tirelessly answers tons of support questions.

Joined: 10/9/2004(UTC)
Posts: 2,549
Location: United States

Thanks: 142 times
Was thanked: 358 time(s) in 199 post(s)
TheNerd wrote:
TheNerd wrote:
I've gone and installed this beta on a clean install of dnn 5 (latest version) and went in to make a post. The odd thing is, the MOMENTI make the post, the wpw3 worker process on the server completely crashes and all of IIS needs to be reset in order for the system to recover. It happens on a post, an edit, a reply - anything that involves the message. I'm completely at a loss as to how to trouble shoot this - seems like its isolated to me, although I don't know why. this is a dedicated server with a clean install of YAF beta 3 and DNN 5. Jaben, can you point me in any direction as to what to look for? What happens during a post?


So I've narrowed it down to the CreateMail.WatchEmail(nMessageID); line in postmessage.ascx.cs

The interesting thing is I have the webconfig file set up to look at the mail.config. Mail.config is set up properly with the same settings that DNN is configured with, and DNN has no problems sending to this email server. Is there another configuration I am missing somewhere?????

Make sure this is in your web.config:

<system.net>
<mailSettings>
<smtp configSource="mail.config"/>
</mailSettings>
</system.net>
Offline kainthedragoonx  
#59 Posted : Wednesday, November 4, 2009 11:28:12 AM(UTC)
kainthedragoonx


Rank: YAF Lover

Reputation:

Joined: 4/23/2007(UTC)
Posts: 42

Thanks: 2 times
Was thanked: 4 time(s) in 4 post(s)
DJGray wrote:

Having serious difficulty with the Membership section of the web.config. No one can log in. Have tried multiple permutations of the readme instructions and still getting no joy.



I've having the same issue on my site.

I want to interface .4 into a full site I am developing, and attempting to step through each part one at a time.

I am upgrading from YAF 1.9.1.2 and cannot lose my user base as is.

Here is what I've done so far:

Exclamation Downloaded the source files for 1.9.4 Beta 3.
Exclamation opened the Beta 3 source and compiled without error
Exclamation created a new web site in VS Web Express 2008
Exclamation Created a sub directory for my forums on my main site
Exclamation copied all files from the YetAnotherForum.Net Web Site into the sub directory of my main site.
Exclamation Deleted the default web.config created by VS 2008 when creating a new web site
Exclamation copied v191-upgrade-web.config from YetAnotherForum.NET\webconfigs to my root website
Exclamation renamed that config to web.config
Exclamation changed the connection string to point to my 1.9.1.2 database
Exclamation built the new website
Exclamation launched Firefox and opened http://localhost/newsite/forums/install/default.aspx
Exclamation ran through the installation package, with success.
Exclamation open http://localhost/newsite/forums/default.aspx and see the posts and what not
Exclamation attempt to log in as myself, receive "The user name or password entered is incorrect. Please try again."
--insert random head to keyboard smash-- Cursing
Exclamation Next I open SQL Server (2005 btw) and open the yaf_user tables...and see all the users listed in there
Exclamation I create a quick login page at the root site...and step through the code...It seems the Membership object cannot find any users.

Any ideas on what I did wrong?

Here is my web.config:

Code:
<roleManager enabled="true" defaultProvider="YafRoleProvider">
			<providers>
				<clear/>
				<add connectionStringName="yafnet" applicationName="Table Top Gamers" name="YafRoleProvider" type="YAF.Providers.Roles.YafRoleProvider"/>
			</providers>
		</roleManager>
		<membership defaultProvider="YafMembershipProvider" hashAlgorithmType="MD5">
			<providers>
				<clear/>
				<add connectionStringName="yafnet" applicationName="Table Top Gamers" name="YafMembershipProvider" requiresUniqueEmail="false" type="YAF.Providers.Membership.YafMembershipProvider" hashHex="true" hashCase="upper"/>
			</providers>
		</membership>
		<profile enabled="true" defaultProvider="YafProfileProvider" inherits="YAF.Classes.Utils.YafUserProfile">
			<providers>
				<clear/>
				<add connectionStringName="yafnet" applicationName="Table Top Gamers" name="YafProfileProvider" type="YAF.Providers.Profile.YafProfileProvider"/>
			</providers>
		</profile>



The end Goal is to make it possible to use the ASP.Net default membership functionality...but I wanted to step through one step at a time.

Any thoughts?

Offline Jaben  
#60 Posted : Wednesday, November 4, 2009 2:11:59 PM(UTC)
Jaben


Rank: YAF Developer

Reputation:

Medals: Medal of Honor Key: Given to pillars of the community who are key players in the YAF community and project.YAF.NET Supporter: Loves YAF.NET!YAF.NET Supporter: Supports our efforts. Thank you.Medal of Honor for the Support King: Given to a community member who tirelessly answers tons of support questions.

Joined: 10/9/2004(UTC)
Posts: 2,549
Location: United States

Thanks: 142 times
Was thanked: 358 time(s) in 199 post(s)
I don't recommend having spacing in your applicationName. I suggest: applicationName="TableTopGamers". Settings look fine... you ran the migration code?
Rss Feed  Atom Feed
Users browsing this topic
6 Pages«<23456>
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Notification

Icon
Error