YAFLogo

xjohny
  • xjohny
  • 65.6% (Friendly)
  • YAF Camper Topic Starter
13 years ago
I've upgraded my forum from 1.9.1 to 1.9.3 recently. Everything works perfect, almost all users can log in and write posts, almost... There is one specific user that cannot log in, even if I (as admin) reset his password. It does not work either.

I've been going through the database tables, but I didn't find anything suspicious with this user. Any hint??

Thanks!

EDIT: Well, perhaps this is related to this problem ...

Sponsor

xjohny
  • xjohny
  • 65.6% (Friendly)
  • YAF Camper Topic Starter
13 years ago
We tried to work-around this issue by creating a new user.

The original name was: "hd1903"

The user created: "hd1903."

Neither the second username worked :cry: Then I tested username "tester1" and that worked...

Isn't that strange?

Ederon
  • Ederon
  • 100% (Exalted)
  • YAF Developer
13 years ago
Did you create tester1 yourself?
When I post FP:Ederon in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting.
xjohny
  • xjohny
  • 65.6% (Friendly)
  • YAF Camper Topic Starter
13 years ago
Yes, I created the tester1 user by going through the common register process.
Ederon
  • Ederon
  • 100% (Exalted)
  • YAF Developer
13 years ago
And how did you create hd1903 user?
When I post FP:Ederon in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting.
Jaben
  • Jaben
  • 100% (Exalted)
  • YAF Developer
13 years ago
Make sure the user is assigned to at least one role/group is you created the user in the admin system.
xjohny
  • xjohny
  • 65.6% (Friendly)
  • YAF Camper Topic Starter
13 years ago
Jaben wrote:

Make sure the user is assigned to at least one role/group is you created the user in the admin system.

The user has "Member" role assigned.

- "Is Approved" checkbox checked

- user is not suspended

EDIT: Now I tested the creation of "hd1903." username and it worked indeed. So I reset the password of the original user to comply with standards (1 alphanumeric + 1 number) and I can now log in with that user successfully!!!