GendrixonEvgeny
2017-11-08T09:33:41Z
Added a page to the forum for news.

Conclusion with IPB: (good)
Sn8_gTEdSJqNWRWVKydwFQ.png

Click to View Image47 View(s)



Conclusion with YAF: (bad)
tR4D1jE2TzeQKrj4th2P8Q.png

Click to View Image45 View(s)




Added by: YAF/controls/News.ascx like that https://www.codeproject....d-in-an-ASP-NET-Web-Page 

Added to YAF/pages/forum.ascx for the test

<%@ Register TagPrefix="YAF" TagName="News" Src="../controls/News.ascx" %>
<YAF:News ID="News" runat="server"/>
Sponsor
GendrixonEvgeny
2017-11-12T12:05:35Z
The problem remains unresolved. On the main page of the forum you need to bring news (RSS) from the topic with news. But for some reason we get an error using the RCC from our YAF Forum. With the rest of the streams, for example with the IPB/IPS everything is fine.
tha_watcha
2017-11-12T12:12:02Z
Originally Posted by: GendrixonEvgeny 

The problem remains unresolved. On the main page of the forum you need to bring news (RSS) from the topic with news. But for some reason we get an error using the RCC from our YAF Forum. With the rest of the streams, for example with the IPB/IPS everything is fine.



Sorry but we can not help you with custom code

<YAF:News ID="News" runat="server"/>


that part of code is not part of YAF. And you don't post here any code to help you. Instead of using code you could try to use widgets instead for example

https://feed.mikle.com/ 




UserPostedImage
GendrixonEvgeny
2017-11-25T18:16:09Z
Originally Posted by: tha_watcha 

Originally Posted by: GendrixonEvgeny 

The problem remains unresolved. On the main page of the forum you need to bring news (RSS) from the topic with news. But for some reason we get an error using the RCC from our YAF Forum. With the rest of the streams, for example with the IPB/IPS everything is fine.



Sorry but we can not help you with custom code

<YAF:News ID="News" runat="server"/>


that part of code is not part of YAF. And you don't post here any code to help you. Instead of using code you could try to use widgets instead for example

https://feed.mikle.com/ 




Good evening. I would not like to use extraneous widgets ... Is there an opportunity for the forum to display news from this topic on a kastum? In the first message, I published a link to the code that works and was successfully added to the forum. But unfortunately it does not work with the threads of the YAF forum itself.

It is necessary to understand for what reasons we receive an error using a link of the form: http :// www .yetanotherforum. net/forum/rsstopic/ft0-forum-rss?pg=3

If we use a link like: https ://lenta. ru/rss/news that all works flawlessly.
tha_watcha
2017-11-26T13:16:30Z
I tested the the code from Codeproject and the forum link works without problems

rss.PNG

Click to View Image40 View(s)



You have not provided what that control

<YAF:News ID="News" runat="server"/>


actually does, or any code
UserPostedImage
GendrixonEvgeny
2017-11-26T15:35:57Z
Originally Posted by: tha_watcha 

I tested the the code from Codeproject and the forum link works without problems

rss.PNG

Click to View Image40 View(s)



You have not provided what that control

<YAF:News ID="News" runat="server"/>


actually does, or any code



I'm sorry, it's working. In view of the fact that in this forum my IP address is regularly blocked - I received this error ...
Users browsing this topic

    About Us

    The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

    Powered by Resharper Donate with PayPal button

    Project Twitter Updates

    Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved