YAFLogo

cybert2t
  • cybert2t
  • 60.8% (Friendly)
  • YAF Camper Topic Starter
10 years ago
Greetings Yaf.Net Team:

I just downloaded the last release version YAF-v1.9.5.5-RTW source code from your site.

I opened the solution in VS2008.

When I try to compile the solution I get a lot of compile errors.

And get the following messages:

--------------------------------------------------------

------ Build started: Project: YAF.Types, Configuration: Debug Any CPU ------

Project file contains ToolsVersion="4.0", which is not supported by this version of MSBuild. Treating the project as if it had ToolsVersion="3.5".

-------------------------------------------------------------

It seems that the source code is for .NET v4

But in your site it says that it is available for .net v3.5 and above. I'm having .net 3.5 SP1 installed in my PC with VS2008.

Do I have to compile in VS2010?

I want to integrate the yaf forum to my current web application that is being developped in VS2008. So I need to compile the yaf proyects in VS2008.

If I need to compile in VS2010, what can I do to integrate it in my current web application being developped in VS2008?

Thanks in advance

Henny

Sponsor

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
10 years ago
Yes you need VS2010 for Yaf 1.9.5.5 or higher. Yaf 1.96 will be .NET 4 only.

If you want to migrate your existing site to vs2010 you need to convert the project, which does Visual Studio autom. When you open the Project.

cybert2t
  • cybert2t
  • 60.8% (Friendly)
  • YAF Camper Topic Starter
10 years ago
Hello:

Thank you for your quick answer.

Unfortunatelly I have no VS2010, so I can use VS2008 only.

Please, could you tell me wich is the latest YAF version for VS2008??

Thank you

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
10 years ago
Yaf 1.95 was the last version that is compatible with vs 2008. But you can also use Vs 2010 Express for yaf which is free.
cybert2t
  • cybert2t
  • 60.8% (Friendly)
  • YAF Camper Topic Starter
10 years ago
Ok, I´m downloading VS2010 Express Edition

Thank you very much.