tviney
  •  tviney
  • 50.2% (Neutral)
  • YAF Forumling Topic Starter
2012-12-29T17:31:10Z
Hey guys, first time poster here.

I did a search and could not find a resolution to my issue.

Issue is...My YAF.WhatsNew module is displaying 7 copies of the same post.

http://www.dailyjumper.com/dotnetnuke 

http://192.96.215.122/Home.aspx 

I tried to compare the two modules to see if something changed, but 1.95 is used on the staging site and 1.96 on the production site. The settings in common for both sites is identical...any ideas?

Thanks.
Sponsor
tviney
  •  tviney
  • 50.2% (Neutral)
  • YAF Forumling Topic Starter
2012-12-29T18:13:52Z
Additional information:

Installation Type: DNN v7.
ASP.Net: v4.0
Server OS: Win2008 R2
SQL Server: 2008 R2
YAF 1.96.1-5114

Originally, the site was not a DNN site but used YAF. I'm afraid I don't know which version.
The original YAF was converted to DNN with module 1.95.5 installed on the test server.
All of this went well without an issue. Forums looked great, content preserved.

I added a YAF.WhatsNew to the front page to list 7 newest posts and this worked.

The site was moved to our new server and upgraded to v1.96.1 of YAF as YAF required a reinstallation as part of the migration. The forums and data are all there and look good still, but the YAF.WhatsNew module now only shows 7 copies of the most recent post. Delete the most recent post and it will show 7 copies of the post made before that.

I notice that in the YAF.WhatsNew Settings there are 3 text boxes

top and bottom contain open and closing HTML for unsorted list and the center contains...

<li class="YafPosts">[LASTPOSTICON]&nbsp;<strong>[TOPICLINK]</strong>&nbsp;([FORUMLINK])<br />[BYTEXT]&nbsp;[LASTUSERLINK]&nbsp;[LASTPOSTEDDATETIME]</li>

So there we are...this used to work in 1.95 and seems broken in 1.96 or I'm missing something and could use some help.

Thanks.
tviney
  •  tviney
  • 50.2% (Neutral)
  • YAF Forumling Topic Starter
2012-12-29T20:38:09Z
I was able to manually uninstall v1.96 from the test server, restore the database and install 1.95 again, and it is now working as intended.

tha_watcha
2012-12-30T07:54:49Z
Originally Posted by: tviney 

Hey guys, first time poster here.

I did a search and could not find a resolution to my issue.

Issue is...My YAF.WhatsNew module is displaying 7 copies of the same post.

http://www.dailyjumper.com/dotnetnuke 

http://192.96.215.122/Home.aspx 

I tried to compare the two modules to see if something changed, but 1.95 is used on the staging site and 1.96 on the production site. The settings in common for both sites is identical...any ideas?

Thanks.



Its a known Bug, i fixed it a few weeks ago

I updated the downloads, with the fixed Code. Simply re-download and install again if possible

http://dnnyafnet.codeplex.com/releases/view/84988 

UserPostedImage

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved