YAFLogo

tommy382
  • tommy382
  • 100% (Exalted)
  • YAF Commander Topic Starter
2014-03-25T15:51:57Z
When clicking on "Mark All as Read" when there is no unread topic, forum crash. One quick repeatable step is:

1. Click on My Topics

2. Click on Unread Topics

3. Assuming there is no unread topic, click on Mark All As Read <--- Crash.

Diff below showed the fix on top of v2.1.1. Please incorporate. the diff show many changes but really there is only one change: check this.topics for null before accessing the Rows property.

Sponsor
JP
  • JP
  • 100% (Exalted)
  • YAF Leader
2014-03-25T17:43:29Z
Same happens for me when I try the scenario (v 2.1.1).

I don't even get a list of unread topics either... 😕

I suppose this has some coincidence with the "find last unread" issue that emerged with 2.x.x.. Just speculating....


He who asks a question is a fool for five minutes. He who does not ask a question remains a fool forever. [Old Chinese Proverb]
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.0
2014-03-26T10:39:36Z
Originally Posted by: tommy382 

When clicking on "Mark All as Read" when there is no unread topic, forum crash. One quick repeatable step is:

1. Click on My Topics

2. Click on Unread Topics

3. Assuming there is no unread topic, click on Mark All As Read <--- Crash.

Diff below showed the fix on top of v2.1.1. Please incorporate. the diff show many changes but really there is only one change: check this.topics for null before accessing the Rows property.

Thanks fix will be included in 2.1.2


UserPostedImage