YAFLogo

mikeoasis
  • mikeoasis
  • 56.8% (Neutral)
  • YAF Forumling Topic Starter YAF Version: newinstall
a month ago
Both the sql-install zip and the sample-app zip access the database but go on an endless loop trying to select from the yaf_board table that does not exist

How can I build the empty database?

 

Sponsor
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
a month ago
Thanks for the report! The issue with the new installation will be fixed with the next release 3.1.4, which will be released on the weekend.
mikeoasis
  • mikeoasis
  • 56.8% (Neutral)
  • YAF Forumling Topic Starter YAF Version: newinstall
a month ago
That's great to hear thanks - once I get it up and running, I would also like to get the source code running in VS 2019 if possible - I need to build an SSO integration ASAP 
tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
28 days ago
New version is out. in theory it should also run in vs 2019
mikeoasis
  • mikeoasis
  • 56.8% (Neutral)
  • YAF Forumling Topic Starter YAF Version: newinstall
28 days ago
Unfortunately the source won't compile because namespace declarations end in semi-colons - instead of wrapping in brackets?

/ *********************************************************************** // // Copyright (c) ServiceStack, Inc. All Rights Reserved. // // Fork for YetAnotherForum.NET, Licensed under the Apache License, Version 2.0 // *********************************************************************** namespace ServiceStack.Text; using System; using System.Collections.Generic; using System.IO; using System.Linq; using System.Reflection; using ServiceStack.Text.Common;

Can you let me know why this is?

 

mikeoasis
  • mikeoasis
  • 56.8% (Neutral)
  • YAF Forumling Topic Starter YAF Version: newinstall
28 days ago
Next I tried the sample app - and got much further all the way to "Initialize Database" - this is good but then the crash:

Could not load type 'ServiceStack.DataAnnotations.ReferenceFieldAttribute' from assembly 'ServiceStack, Version=6.0.0.0, Culture=neutral, PublicKeyToken=02c12cbda47e6587'.

tha_watcha
  • tha_watcha
  • 100% (Exalted)
  • YAF.NET Project Lead 🤴 YAF Version: 3.0.3
28 days ago
Originally Posted by: mikeoasis 

Unfortunately the source won't compile because namespace declarations end in semi-colons - instead of wrapping in brackets?

/ *********************************************************************** // // Copyright (c) ServiceStack, Inc. All Rights Reserved. // // Fork for YetAnotherForum.NET, Licensed under the Apache License, Version 2.0 // *********************************************************************** namespace ServiceStack.Text; using System; using System.Collections.Generic; using System.IO; using System.Linq; using System.Reflection; using ServiceStack.Text.Common;

Can you let me know why this is?

 

That's one of the new c# 10 features. It works on visual studio 2022. But I have not tested it on vs 2019. I check that in the next few days 

mikeoasis
  • mikeoasis
  • 56.8% (Neutral)
  • YAF Forumling Topic Starter YAF Version: newinstall
27 days ago
Thanks didn't realize that, I'll upgrade to 2022 then
mikeoasis
  • mikeoasis
  • 56.8% (Neutral)
  • YAF Forumling Topic Starter YAF Version: newinstall
27 days ago
An update: the source is running nicely via Visual Studio 2022 thanks for your help