guest
2007-11-12T01:44:24Z
Hi,

I'm a complete newb to this stuff and I'm having problems with the installation. I've got to the point in the installation where it tells me to ensure I have a vaild connection string in the web.config file. I have already put a valid connection string in my yafnet.config, so do I just need to copy that into web.config? If so, where abouts in web.config should I put it?
Very basic level instructions would be appreciated as I am completely new to this stuff! :P

Thanks
Alex
Sponsor
guest
2007-11-12T07:13:49Z
It depends. I installed mine with GoDaddy and didnt have to make a single change. Where are you installing this?
Mek
  •  Mek
  • 100% (Exalted)
  • YAF Developer
2007-11-12T09:56:41Z
install.txt is in the route which has the basic level instructions.

Basically it should be telling you rename default.config to web.config and then alter the existing connection string to your own.

The reference to yafnet.config sounds like your barking up the wrong tree.

UserPostedImage 

"It's a case of RTFM.. the only problem being we don't have a manual!"

When I post FP:Mek in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting. (Yes I stole this off Ederon 🙂 )
guest
2007-11-13T00:20:28Z
I did read install.txt, here's what it says:

1. Unzip to a folder available from your web server.

2. If you do not already have a "Web.Config" file, rename default.config
to web.config. If you do have a "web.config", merge default.config
changes with it.

3. Open up "yafnet.config" and modify connstr to a valid database connection
string for your SQL Server 2000/2005/Express database.
The database that yaf
points too should already exist.

3. If YetAnotherForum.net isn't installed at the root of your web
server, make sure the files in the bin directory of the zip file
is copied to /bin on your web server. Also you'll need to add the
<root> element to the yafnet.config to point to the correct URL.
Example: If you have install the forum in the directory "/forum/yaf/"
you will need to add <root>/forum/yaf/</root> to web.config.

4. Open the file <YAFroot>install/default.aspx on your web site. If you
are testing on your local computer, under a directory called
YetAnotherForum.Net, the address should be:
http://localhost/yetanotherforum.net/install/

5. Follow the directions and log in with the administration account
you created during the setup.


I'll followed these instructions exactly and I'm now on step 5, the installation wizard:

Step 2 of 5: Connect to database
Please verify that you have manually modified the connection string found in "C:\Inetpub\wwwroot\YAF\Web.config" to point to your database.

When you have entered the correct connection string, click next to continue with the installation.


It's just not apparant where I enter the connection string in web.config...

Jaben
  •  Jaben
  • 100% (Exalted)
  • YAF Developer
2007-11-13T01:53:08Z
Just ignore that. It's out of date. Thanks for pointing this out. It will be updated.

The install.txt is the latest.

EDIT: Updated in v1.9.1.5.
guest
2007-11-13T03:06:55Z
Hi, Thanks for your help so far. Another question if I may:

I'm doing this from work and we have SQL server 2005 installed on a dev server. I've created the database on the dev server and called it YAF. What's confusing me is the id and password in the connection string. Should this be the id and password for the dev server or the actual database? As far as I can remember I didn't setup a username and password for the database, so would I need to do that?
This is how the connection string looks at the moment:
<connstr>user id=sa;pwd=*server_password*;data source=dev;initial catalog=YAF;timeout=90</connstr>
Using this I keep getting the error:
"Login failed for user 'sa'. The user is not associated with a trusted SQL Server connection."

Just thought I'd mention this; I've created a access project and linked it to this database on the dev server. I've put that project in the YAF root folder. Setting that up connected to the dev server automatically, so can I link to that project in the connection string instead?

Can someone point me in the right direction please, I'm so lost! 😛
Mek
  •  Mek
  • 100% (Exalted)
  • YAF Developer
2007-11-13T03:53:03Z
引用:

Should this be the id and password for the dev server or the actual database? As far as I can remember I didn't setup a username and password for the database, so would I need to do that?



That is entirely dependant on whether you setup SQL Server 2005 using Mix-mode authentication or just Windows authentiaction.

If you did mix-mode you can create a user in Databases - yaf (or database name if you cahgned it) - security. Right click on security and new user. Since your running it on DEV give it something like Database Owner Permissions. Then you'll be fine.

If your going Windows authentication... try something like

"data source=(local);initial catalog=yafnet;integrated security=SSPI"
as your connection string.



UserPostedImage 

"It's a case of RTFM.. the only problem being we don't have a manual!"

When I post FP:Mek in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting. (Yes I stole this off Ederon 🙂 )
guest
2007-11-13T04:19:46Z
Excellent, got it working. Thanks for your help.
Mek
  •  Mek
  • 100% (Exalted)
  • YAF Developer
2007-11-13T06:43:53Z
hurray! Glad it worked.

UserPostedImage 

"It's a case of RTFM.. the only problem being we don't have a manual!"

When I post FP:Mek in a topic, I'm leaving my footprint there so I can track it once I get into coding/supporting. (Yes I stole this off Ederon 🙂 )
dilson
  •  dilson
  • 52.4% (Neutral)
  • YAF Forumling
2008-06-13T18:44:19Z
hi, i have the same problem log in failed for user 'MYPC\ASPNET',
BTW, im using sql server 2000.

1.i created a new table in sql server 2000 called 'Forum'
2.i created new login user 'yaf' and password 'yaf1', pointed the database to 'Forum', and in the tab database
access i check permit the 'Forum' database and permit database role 'public' and 'db_owner'.
3.i have this in web.config
<connstr>uid=yaf;pwd=yaf1;data source=(local);initial catalog=Forum;Integrated Security=True</connstr>

but still im having the same problem,am i missing somthing?? please help.

About Us

The YAF.NET is an open source .NET forum project. YAF.NET is supported by an team of international developers who are build community by building community software.

Powered by Resharper Donate with PayPal button

Project Twitter Updates

Copyright © YetAnotherForum.NET & Ingo Herbote. All rights reserved